Comment 0 for bug 1584050

Revision history for this message
Jacek Parszuto (jacek-parszuto) wrote :


Running OpenStack Liberty Autopilot on Ubuntu 14.04. Commissioning in MAAS went fine and once node was in 'Ready' state I tried to 'Add Hardware' to already deployed cloud. It was going fine until machine had to reboot and was unable to boot under PXE instructions from local drive (probably due to way the drives were configured - two drives in RAID0 as virtual drive + third drive just loose). Now I can't 'Add Hardware' any more and activity "Add Juju machine for 'CL02-03.maas'" is in progress ever since, over 24 hours now. Going to that activity (Standalone -> Activities -> Selecting "Change configuration for region 'office'") all buttons are inactive so it is impossible to cancel. Also tried cancelling using CLI "landscape-api cancel-activities id:405" but it returns empty object and activity remains. Trying to remove every next activity (up to id:412) responds with HTTP 400. I tried restarting all landscape services (lsctl restart). Is there anything else I can try to clear the state of landscape?