Landscape GUI hangs after unsuccessful "Add Hardware".

Bug #1584050 reported by Jacek Parszuto
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Landscape Server

Bug Description


Running OpenStack Liberty Autopilot on Ubuntu 14.04. Commissioning in MAAS went fine and once node was in 'Ready' state I tried to 'Add Hardware' to already deployed cloud. It was going fine until machine had to reboot and was unable to boot under PXE instructions from local drive (probably due to way the drives were configured - two drives in RAID0 as virtual drive + third drive just loose). Now I can't 'Add Hardware' any more and activity "Add Juju machine for 'CL02-03.maas'" is in progress ever since, over 24 hours now. Going to that activity (Standalone -> Activities -> Selecting "Change configuration for region 'office'") all buttons are inactive so it is impossible to cancel. Also tried cancelling using CLI "landscape-api cancel-activities id:405" but it returns empty object and activity remains. Trying to remove every next activity (up to id:412) responds with Status 400, Error Message: 406. I tried restarting all landscape services (lsctl restart). Is there anything else I can try to clear the state of landscape?


Revision history for this message
Jacek Parszuto (jacek-parszuto) wrote :
information type: Proprietary → Public
description: updated
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Unfortunately add-hardware can't recover from some failures yet and that activity will stay pending forever. That also means you cannot use the add-hardware feature again while it's in that state.

Changed in landscape:
status: New → Confirmed
Revision history for this message
Jacek Parszuto (jacek-parszuto) wrote :

Is there any other way I could try to add a node to openstack? For example would this work: boot with MAAS, register with landscape and then use juju?

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

You could access the inner juju environment where this cloud is deployed and use "juju add-unit" for nova-compute, base-machine and ceph or swift. The new unit(s) would become landscape registered computers as usual, and I think even the cloud dashboard would account for them.

To access the inner environment, you first have to login on the landscape-server unit that deployed your cloud (that would be landscape-server/0 if you have only one unit). If you deployed landscape with juju, this command should do all the right things:

juju ssh landscape-server/0 sudo 'JUJU_HOME=/var/lib/landscape/juju-homes/`sudo ls -rt /var/lib/landscape/juju-homes/ | tail -1` sudo -u landscape -E bash'

It will land you in a shell as the landscape user, and with JUJU_HOME pointing at the environment where the cloud is deployed. Do a juju status there to confirm you can see all the cloud services. Then it's a matter of "juju add-unit" as explained before. Note that we install some services on the same node, something you can achieve also via "juju deploy <service> --to N" where "N" is the juju machine id (an integer).

You are in unsupported territory here, though, since you are changing the environment under landscape's feet. You shouldn't try this if you are not familiar with juju and OpenStack services.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.