Comment 62 for bug 1562249

Revision history for this message
Robin (robinrego) wrote :

Hi Jon and Scott.. I tried to test the fix but I am unable to do so. I am looking for someone to help me with this. Here is what I tried so far.

First I was hoping to test this fix for ubuntu Server 14.04.5 LTS. Even after a fresh install, I had no success. So I figured the fix here is only for Xenial... and so I started over.

After a fresh install of Xenial server 16.04 LTS. I did the following to install the -proposed pkg.

sudo nano /etc/apt/sources.list:

added line -- > deb xenial-proposed restricted main multiverse universe

then, sudo nano /etc/apt/preferences.d/proposed-updates

Added the following lines -->

Package: *
Pin: release a=xenial-proposed
Pin-Priority: 400

then sudo apt-get upgrade

then .. robin@MaaS:~$ sudo apt-cache policy python3-curtin
  Installed: 0.1.0~bzr399-0ubuntu1~16.04.1
  Candidate: 0.1.0~bzr399-0ubuntu1~16.04.1
  Version table:
     0.1.0~bzr425-0ubuntu1~16.04.1 400
        400 xenial-proposed/main amd64 Packages
        400 xenial-proposed/main i386 Packages
 *** 0.1.0~bzr399-0ubuntu1~16.04.1 500
        500 xenial-updates/main amd64 Packages
        500 xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.1.0~bzr365-0ubuntu1 500
        500 xenial/main amd64 Packages
        500 xenial/main i386 Packages

I am guessing I am not able to get the -proposed pkg installed ad I must be doing something wrong. I tried to enlist, coommission and deploy nodes with this .. and the result is that only the hp nodes fail deployment. see attached maas UI screenshot.

I am wondering if I need to install the file: curtin_0.1.0~bzr425.orig.tar.gz but I will need to learn how to how to do that over SSH connection or on the server directly.