Comment 20 for bug 1562249

Revision history for this message
Robin (robinrego) wrote :

I tested the fix but the HP-DL380-G4 and HP-DL380-G5 servers still could not be deployed.

Since this is my first attempt and trying out a fix for a bug, I'd like to describe how I tested and would appreciate guidance if I did not do it right.

SSH into maas server and added ---
sudo add-apt-repository ppa:wesley-wiedenmeier/test2
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

Released hp server nodes and then tried to deploy. No success.

Then I tried doing the same on a fresh install of ubuntu server 14.04 LTS and Maas and the result was the same.. i.e all except the HP G4 & G5 in mysetup could not be deployed.

Please note that I am able to deploy these HP G5 servers if I add the line:

cciss.blacklist=yes modprobe.blacklist=cciss hpsa.hpsa_allow_any=1

to the Global Kernel Parameters (Boot parameters to pass to the kernel by default) section in the Settings for the Maas UI.

However.. that does not help with the DL380-G4 Machine.