Comment 58 for bug 1061069

Revision history for this message
In , Johannes Meixner (jsmeix) wrote :

Currently I work on the Ghostscript 9.10 Release Candidate 1.

But I think we cannot do the "big jump" (see comment#15) for 13.1
because there is at least one more regression when upgrading CUPS:

The YaST printer module.
In particular its "printing via network" and "share printers" stuff
only works up to CUPS 1.5 because it needs CUPS Browsing.
I have to do major work for the YaST printer module to let it
use the cups-browsed from cups-filters for CUPS >= 1.6.

Furthermore there is Dominique Leuenberger's response
regarding "Cups >= 1.6" on <email address hidden>
that reads (excerpt):
... incompatibility is now what we want at this stage; I already
looked at the issue from 'the other' side and it was rather trivial
to make it build with cups 1.5 without loosing functionality (the
cups 1.6 getter/setter functions were used; so I just added macros
to fall back to the old style direct access).

So, let's stay with 1.5 an let's see to get upgraded for 13.2.

I think "incompatibility is now what we want at this stage" is a typo
that should be "incompatibility is not what we want at this stage"
because otherwise "let's stay with 1.5" would not make sense.

Dominique Leuenberger,
is my understanding of what you wrote in that mail correct?