Comment 60 for bug 1875062

Revision history for this message
Ɓukasz Zemczak (sil2100) wrote : Re: [20.04] Keyboard layout not enabled immediately during installation when typing username/password

Just noting down my observations here: I think combining the new logs with the old ones I see one suspicious thing that I already tried investigating earlier, but now I'm more certain of it. It looks like that after setting the locale, there's a lot of errors like:

Jan 20 20:46:18 ubuntu ubiquity: perl: warning: Setting locale failed.
Jan 20 20:46:18 ubuntu ubiquity: perl: warning: Please check that your locale settings:
Jan 20 20:46:18 ubuntu ubiquity: #011LANGUAGE = "nb_NO.UTF-8",
Jan 20 20:46:18 ubuntu ubiquity: are supported and installed on your system.

My earlier guess was that due to the locale not being able to be correctly set, maybe the keyboard layout setting via setxkbmap can also fail due to some incompatibilities with the locale. I tried various combinations of locale-layout though and nothing really seemed to have had the same symptoms. Still, makes me wonder: why does that even happen? Are the respective locale somehow not locale-gen'd?