Comment 24 for bug 562742

Revision history for this message
avdheiden (alain-tomatenplein) wrote :

Same here. I'm running Ubuntu Lucid, 32 bit with 2.6.32-20
Replaced my NIC with a TP-Link Gigabit card based on a r8169 chip.

The card was sometimes not recognized by the kernel driver. I compiled the driver from the realtek site and got the card to work at 100baseTx-FD

I set up the DHCP server for a fixed address but this fails. Random adresses are assigned because apparently the drivers fails to send the correct MAC.

Also, I'm unable to get the card to 1000baseT-HD or 1000baseT-FD which are supported. An ethtool eth0 shows the mode as available. I've tried all the usual stuff like ethtool -s eth0 autoneg off speed..... etc.etc.etc
Did depmod -a and made a new initrd, etc.etc.

I also tried to manipulate the card with mii-tool but got the same result. I'm unable to switch the card in ANY mode. Not even to 10base-T, no autoneg or another duplexing mode.

The Switch is from the same brand and works fine with other 1000baseT equipment like my laptop and NAS. I've tried Cat5e and Cat6 cables but no results either.

My conclusion is that the driver is locked somehow to 100baseTx-FD

On the internet I read about people getting their r8169 devices to work with r1000 or r8168 drivers but I didn't get good results.