Comment 64 for bug 534629

Revision history for this message
trainerbill (athroener) wrote :

I did an upgrade today that updated my likewise version to likewise-open Not only did this update not fix the assume default domain issue but also introduced the same issue with home folder redirection. My home folder is now set to %H/likewise-open/%D/%U. I had to do a sym link to correct the issue because changing the registry entries was not working. This is what I tried:

Using an amd64 system

1. Editing /etc/likewise-open/lsassd.reg
     - Changed to "AssumeDefaultDomain"=dword:00000001
     - Changed to "HomeDirTemplate"="%H/%D/%U"
     - Changed all other references of "%H/likewise-open/%D/%U" to "%H/%D/%U"
2. Ran lwregshell import /etc/likewise-open/lsassd.reg
3. Ran lw-refresh-configuration
4. Rebooted.

Still No Luck

1. Ran lw-edit-reg.
     - Both AssumeDefaultDomain and HomeDir were correct
2. lw-eventlog-cli -s - localhost
     - Showed true on Assume default domain
     - Showed HomeDir to be correct.

Created VM of Ubuntu 10.04.1 server edition i386 and had the same issues.
Created VM of Ubuntu 10.10 amd64 beta. Same version of likewise though it errors with the following error when joining the domain:
    - Lsass Error [code 0x00080047]. 31 (0x1F) ERROR_GEN_FAILURE - Unknown error

Finally I grabbed the newest version of likewise off the official site. Installed it and set the registry options. Refreshed the configuration. Rebooted and viola. Success.

Verdict: Likewise is a mess in Ubuntu and has been for almost 6 months now. Meerkat doesn't look like it is going to fix it either.