Error un re-running automated review

Bug #1936382 reported by Francisco Jimenez Cabrera
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store Server

Bug Description

We got the following issue on the web team but we don't maintain

From Emilia:
"I am getting an error while trying to re-run the automated review here

I am adding a comment and then hitting "Run the automated review again" and I am getting:

Server Error

An error occurred which prevented the page you requested from loading. If this problem continues, please consider reporting this problem by sending an e-mail to <email address hidden>

Sentry ID: 672ed5d54aa2481aaf8ee0cd9101f2fc

I tried this 3 times"

Thank you.

Revision history for this message
Daniel Manrique (roadmr) wrote :

Thanks for filing this!

I looked into it a bit more with Emilia.

The thing here is that there were two revisions held for manual review (presumably because it was requested explicitly by the publisher). Revision 17 and 18 were set for manual review.

Trying to rerun automated review on revision 18 resulted in the above error.

Trying to rerun automated review on revision 17 (the first in the revision sequence that was marked for manual review) worked well.

Once revision 17 was left in a finalized state (approved in this case, but could also have been failed), then rerunning automated review on revision 18 worked as intended.

The Sentry ID shows this error message:

InvalidTransitionError: Can not transition via submit_to_review_queue from ManualReviewPendingState

Changed in snapstore-server:
status: New → Confirmed
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.