Comment 6 for bug 1043118

Revision history for this message
Aaron Roydhouse (aaron-roydhouse) wrote :

I've done more investigation and it mostly points to the libgnomevfs or inotify.

I have tried upgrading Shutter to latest stable release (0.90~ppa4~precise1) but same problem.

I have tried downgrading the libgnomevfs packages from the current 1:2.24.4-1ubuntu2.1 release back to 1:2.24.4-1ubuntu2, then logging out and logging in, but that didn't help either, so I reverted to latest stable.

I have tried increasing the number of files that can be watched with inotify from the default 65535 to 100000, in case between Dropbox and Shutter it was running out (though I only have 5000 Dropbox files and 12 Shutter files).


But that didn't help either. In fact Dropbox stopped working too, says 'Can't access DropBox folder'. Again this is a local filesystem folder. I assume gnomevfs and/or inotify flaked for Dropbox too.

At that stage a full reboot appears to clear the problem, and Shutter and Dropbox sprang to life again. inotify is a kernel service so I guess it is possible that the kernel, inotify, or gnomevfs has some sort of resource leak, and one of them is the root cause of our Shutter problems. Anyone more knowledgeable on inotify think that is a valid theory?

Shutter and Dropbox are pretty mission-critical for me so this Ubuntu 12.04 LTS regression is obsessing me :)