Comment 36 for bug 81689

Revision history for this message
Ian Brandt (ian-ianbrandt) wrote :

I had a symlink in Bazaar that prevented Windows users from checking out the project. I've removed the symlink, added a copy of the file in its place, and committed a new revision. On Windows I still get the same error trying to branch the project. Does this bug apply if there is a symlink anywhere in the history of the project? I would have thought a checkout would work if the latest revision contains no symlinks.

More details from IRC:

[12:14pm] ianbrandt: abentley: Hello. I noticed you started the wiki page on Windows symlink support ( Do you know if there is any workaround for getting "bzr: ERROR: Unable to create symlink 'foo' on this platform" on checkout even after the 'foo' symlink has been removed and replaced with a file in the latest commit?
[12:15pm] abentley: ianbrandt: No, if the symlink was removed in the latest commit, I'm surprised that you can't do a checkout.
[12:17pm] ianbrandt: abentley: Okay. Me too. This is with 2.5.1. On my mac when I do revno I get 4102. Same on Windows where the repository was checkout out, but the tree failed to populate.
[12:21pm] ianbrandt: bzr ls -R --kind=symlink at the root of the project returns nothing on my mac.
[12:21pm] ianbrandt: bzr revert -r 4102 on Windows results in "bzr: ERROR: No final name for trans_id 'new-1120' file-id: None root trans-id: 'new-0'"