Include USB drivers in linux-modules

Bug #2037938 reported by Juerg Haefliger
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-raspi (Ubuntu)
Status tracked in Mantic
Jammy
Fix Committed
Undecided
Unassigned
Lunar
Fix Committed
Undecided
Unassigned
Mantic
Fix Released
Undecided
Unassigned

Bug Description

[Impact]

UC22 users are using wifi dongles and drivers are missing in the pi-kernel snap. I.e., Some useful USB drivers (specifically for USB wifi dongles) are missing in linux-modules, so include (almost) all USB drivers in linux-modules.

[Fix]

They're small enough, so include most USB drivers in linux-modules.

[Test Case]

Install kernel and inspect installed modules.

[Regression Potential]

More modules that might get loaded -> kernel crashes, stack traces, hangs, ...

Juerg Haefliger (juergh)
Changed in linux-raspi (Ubuntu Mantic):
status: New → Fix Committed
Juerg Haefliger (juergh)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-raspi (Ubuntu Jammy):
status: New → Confirmed
Juerg Haefliger (juergh)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (8.8 KiB)

This bug was fixed in the package linux-raspi - 6.5.0-1004.6

---------------
linux-raspi (6.5.0-1004.6) mantic; urgency=medium

  * mantic/linux-raspi: 6.5.0-1004.6 -proposed tracker (LP: #2037558)

  * Include USB drivers in linux-modules (LP: #2037938)
    - [Packaging] raspi: Include most USB modules in linux-modules

  * Exclude DRM drivers from linux-modules (LP: #2037936)
    - [Packaging] raspi: Exclude unlikely DRM modules from linux-modules

  * Miscellaneous Ubuntu changes
    - SAUCE: ARM: dts: Fix broken symlinks
    - [Config] raspi: updateconfigs after update to raspberrypi rpi-6.1.y
      (2023-09-29)
    - [Config] raspi: Modify some RP1 configs to fix build failures
    - [Config] raspi: Set ARCH_BRCMSTB=y
    - [Config] raspi: Set IOMMU_SUPPORT=y and BCM2712_IOMMU=y

  * Miscellaneous upstream changes
    - Revert "ASoC: cs43130: Fix numerator/denominator mixup"
    - overlays: Add a sample hat_map
    - Revert "usb: phy: generic: Get the vbus supply"
    - config: 2712: Update defconfig
    - dts: 2712: Update for device tree
    - bcm2708_fb: Hack out dma support
    - gpio_brcmstb: Allow to build for ARCH_BCM2835
    - Allow RESET_BRCMSTB on ARCH_BCM2835
    - pinctrl: bcm2712 pinctrl/pinconf driver
    - vc4/fkms: Remove use of SMI peripheral
    - mmc: brcmstb: add support for BCM2712
    - sdhci: Add SD Express hook
    - Add new "pispbe" driver (though not yet the Makesfiles or DT required to use
      it)
    - irqchip: irq-bcm2712-mip: Support for 2712's MIP
    - reset: reset-brcmstb-rescal: Support shared use
    - net: macb: Also set DMA coherent mask
    - usb: dwc3: Set DMA and coherent masks early
    - drm/panel/raspberrypi-touchscreen: Insert more delays.
    - PCI: brcmstb: Add BCM2712 support
    - V4L2: Add PiSP opaque formats to V4L2
    - V4L2: Add PiSP compressed formats to V4L2
    - bcm2708_fb: Fix more build warnings
    - dt-binding: mfd: Add binding for Raspberry Pi RP1
    - mfd: Add rp1 driver
    - dt-bindings: clock: Add bindings for Raspberry Pi RP1
    - clk: Add rp1 clock driver
    - dt-bindings: pinctrl: Add bindings for Raspberry Pi RP1
    - pinctrl: Add rp1 driver
    - serial: pl011: rp1 uart support
    - mmc: sdhci-of-dwcmshc: define sdio timeout clocks
    - mmc: sdhci-of-dwcmshc: rp1 sdio changes
    - clk: rp1: Add sdio-clk driver
    - i2c: designware: Add SMBUS quick command support
    - dmaengine: dw-axi-dmac: Fixes for RP1
    - spi: dw: Handle combined tx and rx messages
    - pwm: Add support for RP1 PWM
    - drm: Add RP1 DSI driver
    - drm: Add RP1 DPI driver
    - drm: Add RP1 VEC driver
    - v4l2: Add pisp compression format support to v4l2
    - media: rp1: Add CFE (Camera Front End) support
    - dt-bindings: net: cdns,macb: AXI tuning properties
    - ASoC: dwc: Support set_bclk_ratio
    - ASoC: dwc: Add DMACR handling
    - ASOC: dwc: Improve DMA shutdown
    - ASOC: dwc: Fix 16-bit audio handling
    - ASoC: bcm: Remove dependency on BCM2835 I2S
    - hwmon: Add RP1 ADC and temperature driver
    - mfd: bcm2835-pm: Add support for BCM2712
    - soc: bcm: bcm2835-power: Add support for BCM2712
    - drivers: spi: Fix spi-gpio to correctly implement sck-idle-in...

Read more...

Changed in linux-raspi (Ubuntu Mantic):
status: Fix Committed → Fix Released
Juerg Haefliger (juergh)
Changed in linux-raspi (Ubuntu Lunar):
status: New → Fix Committed
Changed in linux-raspi (Ubuntu Jammy):
status: Confirmed → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-raspi/6.2.0-1016.18 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lunar-linux-raspi' to 'verification-done-lunar-linux-raspi'. If the problem still exists, change the tag 'verification-needed-lunar-linux-raspi' to 'verification-failed-lunar-linux-raspi'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: kernel-spammed-lunar-linux-raspi-v2 verification-needed-lunar-linux-raspi
Revision history for this message
Juerg Haefliger (juergh) wrote :
Download full text (69.5 KiB)

Downloaded linux-modules-6.2.0-1016-raspi_6.2.0-1016.18_arm{64,hf}.deb from lunar-proposed, extracted them and verified the presence of USB modules:

$ find arm* | grep '/usb/'
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/bcd2000
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/bcd2000/snd-bcd2000.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/misc
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/misc/snd-ua101.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/caiaq
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/caiaq/snd-usb-caiaq.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/hiface
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/hiface/snd-usb-hiface.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6/snd-usb-line6.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6/snd-usb-variax.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6/snd-usb-toneport.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6/snd-usb-podhd.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/line6/snd-usb-pod.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/snd-usbmidi-lib.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/6fire
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/6fire/snd-usb-6fire.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/sound/usb/snd-usb-audio.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/common
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/common/ulpi.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/dwc3
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/dwc3/dwc3-of-simple.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/dwc3/dwc3.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/dwc3/dwc3-haps.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/class
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/class/usbtmc.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/class/usblp.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/class/cdc-acm.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/class/cdc-wdm.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/cypress_cy7c63.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/idmouse.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/isight_firmware.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/ezusb.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/usb251xb.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/usblcd.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/appledisplay.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/lvstest.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/yurex.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/usbsevseg.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/emi26.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/ehset.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/misc/ldusb.ko
arm64/lib/modules/6.2.0-1016-raspi/kernel/drivers/usb/mis...

tags: added: verification-done-lunar-linux-raspi
removed: verification-needed-lunar-linux-raspi
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-raspi/5.15.0-1042.45 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-jammy-linux-raspi' to 'verification-done-jammy-linux-raspi'. If the problem still exists, change the tag 'verification-needed-jammy-linux-raspi' to 'verification-failed-jammy-linux-raspi'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: kernel-spammed-jammy-linux-raspi-v2 verification-needed-jammy-linux-raspi
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.