Comment 0 for bug 1770862

Revision history for this message
wereturtle (wereturtle) wrote :

The touchpad on the new ASUS GU501GM (the junior Zephyrus M that is a Best Buy exclusive) does not seem to be detected whatsoever. Below is a printout of "xinput list". I've also attached output files for devices, dmesg, lspci -vnvn, Xorg.0.log, and version.log. I suspect it is an Elantech. I did manage to get one command to print ELAN120x (x being some number). Alas, I don't remember the command now, and none of what I've attached is showing it. (Sorry, I've had a long night of troubleshooting.) The Windows 10 device manager won't even list the brand, even though it's working there. Still, I am fairly confident it's Elan, as that's what ASUS seems to roll with these days.

I've tried various combinations of i8042.* kernel parameters, but to no avail. I've also tried blacklisting i2c_hid. It's like it thinks the touchpad is a keyboard? I'm on Ubuntu 18.04. I've tried the mainstream kernel 4.16.7, also to no avail. The latest release candidate (#4) for 4.17 would not let me log in past SDDM, and I noticed no touchpad miracle while I was in the SDDM login screen.

If you have any further suggestions of what I could try, I would very much appreciate it! Thanks in advance!

xinput list:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ASUSTeK Computer Inc. N-KEY Device id=14 [slave pointer (2)]
⎜ ↳ Logitech USB Optical Mouse id=15 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Asus Wireless Radio Control id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Video Bus id=9 [slave keyboard (3)]
    ↳ Power Button id=10 [slave keyboard (3)]
    ↳ Sleep Button id=11 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=12 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=13 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD id=16 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=17 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=18 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=19 [slave keyboard (3)]