After reboot, the password set at install time doesn't work.

Bug #1948714 reported by Mark Smith
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

After reboot, the password set at install time doesn't work (This happened to me at first in the 24-10-2021 build also, but when I reinstalled over the same VB disk, it worked). I triple-checked the password at install to ensure I wasn't having a senior moment!
I tried just pressing Enter (i.e. no password) and this also didn't work.
So to get here to report this, I had to boot into recovery mode and go to the root command and enter 'sudo passwd <user>'. When I did this, the prompt just asked me for the new password (not the existing password first as I was expecting) as if there was no password set.

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: xorg 1:7.7+22ubuntu2
ProcVersionSignature: Ubuntu 5.13.0-19.19-generic 5.13.14
Uname: Linux 5.13.0-19-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu70
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: pass
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Mon Oct 25 20:47:48 2021
DistUpgraded: Fresh install
DistroCodename: jammy
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
 VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
   Subsystem: VMware SVGA II Adapter [15ad:0405]
InstallationDate: Installed on 2021-10-25 (0 days ago)
InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Alpha amd64 (20211024)
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/12p, 12M
     |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/BOOT/ubuntu_2nlv66@/vmlinuz-5.13.0-19-generic root=ZFS=rpool/ROOT/ubuntu_2nlv66 ro recovery nomodeset dis_ucode_ldr
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install) 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:sku:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr: Virtual Machine VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.107-8ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 21.2.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.13-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-2build1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200714-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.17-1build1

Revision history for this message
Mark Smith (juglugs1974) wrote :
Revision history for this message
Mark Smith (juglugs1974) wrote :

After I submitted this, I realised that the bug could be (probably is) in Ubiquity. Sorry.

Revision history for this message
Mark Smith (juglugs1974) wrote :

Also exists in 20211027 build

affects: xorg (Ubuntu) → ubiquity (Ubuntu)
information type: Private Security → Public Security
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

@juglugs1974 Mark Smith

I cannot reproduce this bug - testing image Ubuntu Jammy 27-10-2021

Could it be that this is related to your bug #1948716 where you report an issue with the keyboard?

Revision history for this message
Mark Smith (juglugs1974) wrote :

Hi Leo,

Interesting. I ran the Ubuntu 21.20 iso through the same VM (used fresh VDI) and I get the same fault. On my actual Ubuntu machine 21.10 was installed with no problems.

So maybe it's a VirtualBox issue?
I don't understand (I mean I really am lacking the knowledge) why the keyboard layout bug would affect this?

I have attached the VB configuration for reference.

Revision history for this message
Mark Smith (juglugs1974) wrote :

New data point: Using build 20211028 and an alpha-character ONLY password works. I'll now test the 21.10 build with that alpha password

Revision history for this message
Mark Smith (juglugs1974) wrote :

OK, so it appears that the bug is if you have a special character in the original password. I don't really want to say which special character and where in the password it appears in this public area, but if you contact me, I'll let you know.

Also, please excuse my ignorance on all of this. I am a complete Noob to Ubuntu testing, but very eager to learn from more experienced people.

Revision history for this message
Mark Smith (juglugs1974) wrote :

I've narrowed it down to a specific special character at any location in the string, and after changing all of my passwords that included it, I can reveal it to be the '#' character. So either pass#word or password# fails.

I am now checking other special characters ('*' works).

Is there a faster way of me doing this than spinning up new VMs and going through the installation each time?

Revision history for this message
Mark Smith (juglugs1974) wrote :

Note: Booting into recovery and setting the password from the command line allows the # character, so it's only in Ubiquity at install that there is a bug.

Revision history for this message
Mark Smith (juglugs1974) wrote :

The '@' character also does not work in any position of the string.

information type: Public Security → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: rls-jj-incoming
Revision history for this message
Brian Murray (brian-murray) wrote :

We have recently updated ubiquity for 22.04 which adds an option to unhide passwords that are being typed. We are doing this because we suspect there is a bug with keyboard layout switching and that might be the root cause of the issue which you have found. Can you try doing a new installation of Ubuntu and confirm that the keys you are pressing are the keys being registered in the password? Thanks in advance!

Changed in ubiquity (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → Incomplete
Revision history for this message
Mark Smith (juglugs1974) wrote :

Hi Brian,

Using the latest daily build (20220126), I cannot see the option to display the password? - see attached screenshot.

I can see your line of thinking as the # symbol is different on US & UK keyboard mappings (much to the annoyance when I lived in the US for 6 years and had to retrain my muscle memory twice!).

I ran an install using the UK keyboard layout with the # symbol from its own key within the password - The issue is still extant.
I tried using the US mapping of Shift+3 to make the # symbol when logging in, but it still failed.

I then ran an install using the US keyboard layout with the # symbol made by pressing Shift+3 within the password - Using the US mapping of Shift+3, I can log in normally.

Kind regards

Revision history for this message
Brian Murray (brian-murray) wrote :

I download a daily image from today, 20220128, and there is an eyeball at the end of the "Choose a password:" text box. Thanks again for your testing but could you try again with a daily build that allows you to see your password as you enter it? Thanks in advance!

Revision history for this message
Mark Smith (juglugs1974) wrote :

I've downloaded and installed using 20220129 which does have the eyeball icon next to the password field.

As seen in the attached screenshot, the keyboard mapping at the password stage doesn't go to UK as previously selected - I had tried to type Thanks#Brian but the keyboard had given me Thanks/Brian.

Revision history for this message
Mark Smith (juglugs1974) wrote :

So I then manually changed the password to read Thanks#Brian by using the US mapping of Shift+3 to get the # symbol as seen in the screenshot.

I let the installer run and logged in successfully using Thanks#Brian directly as I normally would on my UK keyboard.

So, yes, it looks like Unity isn't picking up the keyboard map selection in the initial password entry screen (where you have the eyeball icon now).

Does this then relate to bug #1948716 where I noticed that Unity doesn't 'guess' my keyboard map correctly at the beginning and I have to manually select UK mapping?

Changed in ubiquity (Ubuntu):
assignee: Brian Murray (brian-murray) → nobody
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.