"Try it" installs kwallet differently than "Install now"

Bug #1868646 reported by MarkF
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

ISO testing 20.04 Kubuntu daily image (20200323). Something involving Kwallet & wifi is installed differently depending on whether I take the path "Try Kubuntu" (install from Live desktop), or "Install Kubuntu."

1. When I choose "Try Kubuntu" & install from the Live Desktop, upon first reboot wifi doesn't connect automatically. I have to manually connect which invokes Kwallet & makes me set up a password (with no indication that a null password is acceptable). I end up having to supply Kwallet's password every time I boot (before wifi will connect).

2. When I choose "Install Kubuntu," upon first reboot wifi automatically connects (as all other Ubuntu desktop flavors do). I don't have to mess around with Kwallet.

The #1 behavior has bothered me for awhile. It hasn't felt normal, and would be confusing to new users. It took me a month to learn that I could enter a null password and never be bothered by Kwallet again. I've been debating opening a bug about that. Something didn't feel right about it. But, that's subjective.

Fortunately, I tried "Install Kubuntu" and it worked the way I thought it should have worked. That's not a subjective bug (the install should work the same either way).

IMO, #2 is the proper behavior. Everything works the way a new user would expect. (I strongly feel like #1 is offputting to new users and an unnecessary exposure to something new, before they can proceed much further past the installation. They end up having to enter a 2nd password each time they boot in order to get wifi to work. As I said, I was contemplating opening a subjective bug report about this. I was relieved to see that it may not have been intended to work that way.).

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 23 18:59:13 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed maybe-ubiquity quiet splash ---
InstallationDate: Installed on 2020-03-24 (0 days ago)
InstallationMedia: Kubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200323)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
MarkF (az2008) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
MarkF (az2008)
description: updated
MarkF (az2008)
description: updated
MarkF (az2008)
description: updated
tags: added: kubuntu
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.