all hostnames on network appear taken when changing hostname.

Bug #1398977 reported by Lyn Perrine
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

To reproduce use a lubuntu amd64 iso and isntall on laptop and choose manual partitiong. Then ichoose for a btrfs partition as / and reuse xfs as home. then it asks for timezone and show new york and I switched to Los Angeles. Then it came to enter username and I entered brenda. I wanted to change the hostname from brenda-Hp-pavillion-1230 to something like btrviv and it said it was already taken on the network. I tried typing in more hostnames and it seemed that they already existed on the network but having everything I try to type in be already taken is unlikely ad I tried like 10 different hostnames and still ubiquity said they were all taken. I am connected over wifi with a

wlan0 IEEE 802.11bg ESSID:"Steaksauce"
          Mode:Managed Frequency:2.422 GHz Access Point: C4:3D:C7:A4:41:7C
          Bit Rate=54 Mb/s Tx-Power=20 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=68/70 Signal level=-42 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:29 Invalid misc:48 Missed beacon:0
but I also have a broadcom 4322 on pci that does not work out of the box but it is not using that. Also clicking back and then continue again I would still get that all hostnames are invalid.

Also I am not sure if this is so early in the installer that it fails as it has not installed anything but in my live system netihr /var/log/installer/syslog or /var/log/installer/partman exist

  Installed: 2.21.1
  Candidate: 2.21.1
  Version table:
 *** 2.21.1 0
        500 vivid/main amd64 Packages
        100 /var/lib/dpkg/status

Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

I expected to be able to change my hostname to a valid hostname. Instead I could not change the hostname. I could try using the defualt hostname as a workaround and chaning it later.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.1
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CasperVersion: 1.346
Date: Wed Dec 3 15:38:18 2014
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Lubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141203)
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Revision history for this message
Lyn Perrine (walterorlin) wrote :

One more note on how to reproduce this is I was editing the hostname to customize by pressing backspace which brought it into an invalid hostname with a '-' at the end which could mean that is was an invalid hostname at one point and ubiquity was not seeing the new hostnames after that as valid.

I immediately tried to install again and was successful without editing the hostname and using what automatically fills in the box. I can still get the hostname I want postinstallation by entering sudo editor /etc/hosts and changing the to your desired hostname. I did have to reboot as clicking back would still have an invalid hostname.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

I have reproduced this bug again but now I have a better work around. When ubiquity asks for your name on the page where you create acounts and setup your hostname and it says your custom hostname is invalid put the cursor in the filed for your name and hit backspace to delete the last character of your name then type it again. And it now accepts a valid hostname as valid and continues to install.

tags: added: ubi-network
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.