Installation of 13.04 from live-usb denied (ubiquity / partman error 141)

Bug #1179086 reported by gigi
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

Date: 2013-may-11

I'm trying to install Kubuntu 13.04 on a Dell-Vostro 3560-1792 (core I7, AMD/Intel-Graphics, HD1=500GB, HD2=32 GB SSD).
After the "Prepare"-form, when partman is being started, ubiquity reports :

"ubi-partman failed with exit code 141".

System: Live-USB of Kubuntu 13.04.
lsb_release reports: "Ubuntu 13.04, release 13.04".

apt-cache policy ubiquity:
  installed: 2.14.8
  candidate: 2.14.8
 *** 2.14.8 0
        500 raring-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2.14.6 0
        500 raring/main i386 Packages

Uname: Linux kubuntu 3.8.0-19-generic

I've set up the bios to "ATA-Harddisk-Mode", so the SSD won't be used for a "fake RAID-0", and did a partitioning with the live-usb (kubuntu 13.04) like this:

/dev/sda ( ATA WDC WD5000BPKT-7, 500 GB) :
No. Size Type File system Flags
1 41.1MB primary fat16 diag
2 10.7GB primary linux-swap(v1)
3 162GB primary ext3
4 328GB primary ntfs boot

/dev/sdb (ATA SAMSUNG SSD PM83, 32 GB)
No. Size Type File system Flags
1 32.0GB primary ext4

I installed Windows 7 on /dev/sda4, which worked fine.

Since bug #1080701 was fixed in version 2.14.18, it should be a different problem.
Mounting all partitions before executing ubiquity doesn't change anything.

Apart from partman-log and sys-log I will upload the report of "boot-repair" (

Revision history for this message
gigi (georg-drews) wrote :
Revision history for this message
gigi (georg-drews) wrote :
Revision history for this message
gigi (georg-drews) wrote :
Revision history for this message
gigi (georg-drews) wrote :
Revision history for this message
Matthew Carpenter (matt-eisgr) wrote :

Does this machine have Windows 8 and UEFI on it? I am also having difficulties installing 13.04 on an HP ENVY h8 with similar ressults, and it seems to be tied to the fact that I have a Win8 UEFI partition existing on the drive.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
gigi (georg-drews) wrote :

@Matthew Carpenter (matt-eisgr)
No, the BIOS is not set to UEFI-Mode.
I actually wiped everything on the harddisk and formated the Harddisk and the SSD with 'parted magic'.
After that I did a clean install of windows 7.
During this installation I was asked how to handle the harddisk: as ATA-Disk or together with the SSD as raid.
I chose ATA. The windows-installation wored fine afterwards.
As far as I do understand the situation, there is a 'fake-raid'-controller inside the laptop.
Fake, because this controller does not work on it's own like a real raid-controller, but you need
a special soft-driver. This is pretty much like thos crippled laser-printers for windows, which needed
a special GDI-driver.
I believe, that at the moment there is no proper driver for this 'crippled' raid-controller.

When I tried to install Kubuntu 12.04 (alternate), the installation procedure asked my,
if I wanted to use a raid-driver or use the disks in a plain ATA-Mode.
After choosing 'plain-ATA-Mode', the installation worked fine.

Since there is no 'alternate'-Installer anymore for 13.04, you can only use the offered installer.
And this installer does not ask 'do you want to use a raid-driver' or use an 'ATA-driver'.
It seems the installer realises, that there is a raid-controller-hardware inside the laptop,
automatically loads one (or several - I don't know), and by doing so, the disks can't be controlled
properly, since the raid-controller is 'fake'.

So as far as my researches have gone, the problem lies within the installer.

The only solution to the problem was for me to install 12.04 with the alternate-installer, then
upgrade to 12.10 and then upgrade to 13.04. It's a lot of work, but at least it works.

Lot's of greetings

Mathew Hodson (mhodson)
tags: added: i386 kubuntu raring ubiquity-2.14.8
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.