No tablet pressure in KDE / QT apps, GTK apps work fine

Bug #564420 reported by Shaved Wookie
This bug affects 5 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Fix Released
Won't Fix
Jonathan Thomas

Bug Description

Binary package hint: qt-sdk

Working pressure from my tablet stylus in both QT/KDE apps and GTK apps.

Only GTK apps (eg Gimp, Mypaint etc) work perfectly with tablet pressure. QT apps (Krita / QT's wacom widget etc) still respond to cursor movement and clicks, but have no pressure.

Draw a line in Krita with pressure turned on in the painttop configuration window. Krita has no tablet configuration, relying solely on QT. Pressure doesn't show. Ditto QT's wacom widget.

Dell Latitude XT running Kubuntu Lucid AMD 64, QT 4.6.2 & KDE 4.4.2

Apparently this was patched in Fedora by tzander of Koffice. The patch is from the resulting bug report on QT at:

summary: - QT / KDE apps don't use tablet pressure, GTK apps work fine
+ No tablet pressure in KDE / QT apps, GTK apps work fine
affects: qt-sdk (Ubuntu) → qt4-x11 (Ubuntu)
Revision history for this message
Florian Staudacher (florian-staudacher) wrote :

very annoying bug!

Kubuntu 10.04
with kubuntu experimental ppa

> kde4-config --version
Qt: 4.7.0
KDE: 4.4.3 (KDE 4.4.3)
kde4-config: 1.0

Revision history for this message
Shaved Wookie (shavedwookie) wrote :

Interestingly I was getting this problem on Archlinux until I upgraded to QT 4.7.0-Beta 1 and then it dissapeared. I've got QT 4.7.0-Beta 1 on Kubuntu though and it still doesn't work, so I suspect that the basic problem is fixed but that there's still need for some config fun.

Revision history for this message
David Douard (david-douard) wrote :

As stated above, this bug has been reported in Qt bugtracker

and is announced to be fixed in Qt 4.6.3

Note that it has also been reported to redhat:

So the best fix for this is probably to upgrade Qt to 4.6.3. Any chance to have this fixed in Lucid?

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

I've been meaning to do an update for Lucid with several patches for some of the more major issues. I'll put this one on the pile.
Marking fixed for maverick and opening a lucid task.

Changed in qt4-x11 (Ubuntu):
importance: Undecided → Low
milestone: none → maverick-alpha-2
status: New → Fix Released
Changed in qt4-x11 (Ubuntu Lucid):
assignee: nobody → Jonathan Thomas (echidnaman)
importance: Undecided → Low
status: New → Triaged
milestone: none → lucid-updates
Revision history for this message
Florian Staudacher (florian-staudacher) wrote :

What is the current status of this issue?

kubuntu 10.04
libqt*: 4.6.3-0ubuntu1
xorg: 7.5+6ubuntu~xorgedgers3~lucid
tablet: Bus 005 Device 002: ID 172f:0034 Waltop International Corp.

(still no pressure, in case that wasn't clear)

Revision history for this message
Florian Staudacher (florian-staudacher) wrote :

Ok, sorry for my previous (unnecessary) comment.
Pressure sensitivity worked as soon as I changed from evdev to wacom driver.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in qt4-x11 (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.