13.04 beta 2 plasma active crashes on startup

Bug #1164236 reported by Jonathan Riddell
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
plasma-mobile (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

in 13.04 beta 2 plasma active crashes on startup

Jonathan Riddell (jr)
Changed in plasma-mobile (Ubuntu):
milestone: none → ubuntu-13.04
tags: added: kubuntu
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1164236

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-mobile (Ubuntu):
status: New → Confirmed
Revision history for this message
Benjamin Kay (benkay) wrote :

I've actually rebuilt kubuntu's plasma active source packages (contour, kde-artwork-active, startactive, plasma-mobile, share-like-connect) on debian unstable, so I'm not sure how much my experience applies to this bug. I noticed that that in /usr/bin/startactive someone had wisely commented:

# There's something wrong with d-bus invocation,
# so we are doing a rather dirty forced-launch
# before the real startactive is run

# pkill -u ${USER} dbus-launch
# pkill -u ${USER} dbus-daemon

# unset DBUS_SESSION_BUS_ADDRESS
# unset DBUS_SESSION_BUS_PID

# export `dbus-launch`
# sleep 3

Uncommenting these last 6 commands allowed plasma active to start without crashing on my system. Your mileage may vary.

Jonathan Riddell (jr)
Changed in plasma-mobile (Ubuntu):
milestone: ubuntu-13.04 → ubuntu-13.10
Changed in plasma-mobile (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.