[Multi Monitor] Built-in screen gets enabled changing the entire layout after resuming from the lockscreen

Bug #2018158 reported by Luca Osvaldo Mastromatteo
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)

Bug Description

Hello, first of all I am not entirely sure where to report this

To explain the issue briefly, I have an ASUS TUF F15 laptop and two external monitors connected each to the HDMI and USB-C port with the laptop lid opened but the built-in screen disabled, what happens on the resume from the lock screen (after a couple of minutes, when all the screens go off), the layout gets messed up because the built in screen gets re-enabled automatically, the HDMI screen remains correctly on, but the USB-C screen gets disabled.

I may have a clue on why this happens, I have an NVIDIA optimus setup where the Intel iGPU runs the USB-C monitor and the built-in monitor, the HDMI gets managed from the dedicated NVIDIA card so nothing changes here, and somwhow the builtin screen gets disabled then enabled when resuming the system, resulting in GNOME switching to it automatically as you have plugged in a new screen

No matter how many times you force the screen disabling it, it will happen again.

The workaround is to just to keep closed the laptop lid, of course, but since you can't power it on without the power button is a bit difficult. So I'd just like to keep it open.

Another workaround I found is to unload the asus_nb_wmi and asus_wmi kernel modules as I thought they could be the issue, since they manage this specific platform, but as I said before I am not sure what to expect here, is it the intended behavior from GNOME?

I mean, it's like someone plugs in some screens then the output gets enabled automatically but that's not the case of course, but the asus_wmi module may do some weird things.

What you expected to happen: Resuming from the lock screen with all the screen layout in place
What happened instead: Built-in screen enables itself, USB-C monitor gets disabled, HDMI monitor remains the same, the entire screen layout gets changed
Workaround: Keeping the laptop lid closed or disabling asus_wmi and asus_nb_wmi kernel modules

System affected:
Ubuntu: 23.04 Lunar Lobster, tried also Ubuntu 22.04 and a custom flavor (PopOS 22.04)
Don't mind the custom kernel, I tried different releases, including:
Kernel: 6.2.0-20-generic
Custom 6.2.13 and 6.3.0 kernels

gnome-shell version: GNOME Shell 44.0

Info: inxi -F

  Host: haru-nb Kernel: 6.3.0-x64v4-xanmod1 arch: x86_64 bits: 64
    Desktop: GNOME v: 44.0 Distro: Ubuntu 23.04 (Lunar Lobster)
  Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX516PM_FX516PM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX516PM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX516PM.329 date: 02/01/2023
  ID-1: BAT0 charge: 64.0 Wh (98.9%) condition: 64.7/76.0 Wh (85.1%)
    volts: 15.8 min: 15.8
  Info: quad core model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 3001 min/max: 400/4800 cores: 1: 2068 2: 2607 3: 1718
    4: 2707 5: 4300 6: 4284 7: 4312 8: 2018
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    v: 530.41.03
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.8 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa dri: iris
    gpu: i915,nvidia,nvidia-nvswitch resolution: 1: 2560x1440
    2: 1920x1080~60Hz 3: N/A
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel Xe Graphics (TGL GT2)
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
  Device-2: NVIDIA GA106 High Definition Audio driver: snd_hda_intel
  Device-3: Thesycon System & Consulting GmbH DX3 Pro type: USB
    driver: snd-usb-audio
  Device-4: Logitech Blue Snowball type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.3.0-x64v4-xanmod1 running: yes
  Sound Server-1: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi
  IF: wlo1 state: up mac:
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno2 state: down mac:
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
  IF: enx00e04c6928d4 state: down mac:
  IF-ID-1: virbr0 state: down mac:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb
  Report: hciconfig ID: hci0 state: up address: bt-v: 3.0
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 8.65 TiB used: 3.51 TiB (40.6%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT4000P3SSD8 size: 3.64 TiB
  ID-2: /dev/nvme1n1 vendor: SK Hynix model: HFM512GD3JX013N
    size: 476.94 GiB
  ID-3: /dev/sda type: USB vendor: Seagate model: ST4000DM004-2CV104
    size: 3.64 TiB
  ID-4: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0
    size: 931.51 GiB
  ID-1: / size: 198.66 GiB used: 133.69 GiB (67.3%) fs: ext4
    dev: /dev/nvme1n1p5
  ID-2: /boot/efi size: 298.8 MiB used: 91.1 MiB (30.5%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-1: swap-1 type: file size: 17 GiB used: 204.8 MiB (1.2%) file: /swapfile
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2700
  Processes: 441 Uptime: 1h 49m Memory: 15.35 GiB used: 8.88 GiB (57.9%)
  Shell: Bash inxi: 3.3.25

ProblemType: Bug
DistroRelease: Ubuntu 23.04
Package: gnome-shell 44.0-2ubuntu3
Uname: Linux 6.3.0-x64v4-xanmod1 x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.26.1-0ubuntu2
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Sat Apr 29 20:07:41 2023
DisplayManager: gdm3

RelatedPackageVersions: mutter-common 44.0-2ubuntu4
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Luca Osvaldo Mastromatteo (lukycrociato) wrote :
affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
tags: added: multimonitor suspend-resume
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.