Alt + F2 shortcut does not work on Lubuntu

Bug #1313355 reported by André Campos Rodovalho
This bug affects 10 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Fix Released

Bug Description

Problem on configuration at ~/.config/openbox/lubuntu-rc.xml file is causing the shortcut not to work. The entire original entry is:

   <keybind key="A-F2">
      <action name="Execute">
        <command>lxsession-default launcher_manager</command>

I replaced "<command>lxsession-default launcher_manager</command>" by "<command>lxpanelctl run</command>" and now works!

I'm not sure if the root problem is the shortcut configuration. Maybe is a lxsession-default fault. I tried to run "lxsession-default launcher_manager" on lxterminal and nothing happens, only text output. When I run "lxsession-default file_manager" the pcmanfm actually opens...

I tried to change the configuration regarding "Launch manager" on lxsession-default-apps but I had no success. I replaced "lxpanelctl" by "lxpanelctl run", but behavior was the same...

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: openbox 3.5.2-6
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: LXDE
Date: Sun Apr 27 11:01:56 2014
InstallationDate: Installed on 2014-04-27 (0 days ago)
InstallationMedia: Lubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: openbox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
André Campos Rodovalho (andre-rodovalho) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openbox (Ubuntu):
status: New → Confirmed
Revision history for this message
John Hupp (john.hupp) wrote :

I could add that in one or more earlier versions of Lubuntu Win-R also produced a Run window, but that does not work either.

affects: openbox (Ubuntu) → lubuntu-default-settings (Ubuntu)
Revision history for this message
Lyn Perrine (walterorlin) wrote :

I have found a different fix and work around for this.

change the 2 lines of each shortcut in ~/.config/openbox/lubunturc.xml

<command> lxsession-default launcher_manager</command> to <command>lxsession-default launcher manager</command> with the space and then it works. Oh and run openbox --reconfigure to reload the configuration files for your new openbox configuration.

This also affects utopic. This way If you had something else working other than lxpanel as your launcher you could get the run to work.

tags: added: utopic
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Unit 193 (unit193)
Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Doctor Jellyface (doctorjellyface) wrote :

I confirm the fix proposed at #4 works, only the file is ~/.config/openbox/lubuntu-rc.xml and not ~/.config/openbox/lubunturc.xml

Revision history for this message
Doctor Jellyface (doctorjellyface) wrote :

It also works by changing <command>lxsession-default launcher_manager</command> to <command>lxsession-default launcher</command> on both shortcuts.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.40

lubuntu-default-settings (0.40) utopic; urgency=medium

  [ Julien Lavergne ]
  * usr/share/xsessions/QLubuntu.desktop
   - Use LXQt as environment for the Qt session.
  * debian/control:
   - Depends on xbacklight to make some shortcuts workings (LP: #1313358)
  * usr/share/lubuntu/openbox/*rc.xml
   - Fix C-F7 shortcut (LP: #1313352)
   - Fix launcher shortcuts (LP: #1313355)
  * etc/xdg/lxsession/*/desktop.conf
   - Use Lubuntu of the icons theme.

  [ Unit 193 ]
  * Move etc/ and usr/ under src/
  * Update debhelper compat to level 9.
  * Update standards-version to 3.9.5.
  * qlubuntu-default-session: Alternatively depend on lxqt-lightdm-greeter.
  * d/copyright: Update to copyright format 1.0, update copyright years.
  * d/copyright: Set Julien Lavergne as Upstream-Contact.
  * d/maintscript: Move lightdm config to usr/share, this follows standard
    lightdm config such that the file is removed when the package is.
  * Move d/20-*.conf to src/usr/share/lightdm/lightdm.conf.d/
  * d/rules: Call dh_install with --fail-missing.
  * 20-qlubuntu.conf: The session name is QLubuntu, not qlubuntu.
 -- Julien Lavergne <email address hidden> Wed, 20 Aug 2014 21:49:00 +0200

Changed in lubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.