Maverick kernel breaks video on resume from suspend

Bug #594885 reported by Phillip Susi
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Leann Ogasawara

Bug Description

When resuming from suspend, my display never comes back out of power save mode with the Maverick 2.6.35 kernel. I first noticed this with 2.6.35-2, and today updated to 2.6.35-3 with the same results. I have installed today's daily mainline build from the kernel PPA, 2.6.35-999-061510, and this kernel does not have the issue. Standard Karmic and Lucid also work fine, so this is an Ubuntu specific regression.

When the system does resume, it appears to be functioning other than the display not being initialized correctly. The lock keys on the keyboard toggle the LEDs and I can hit ctrl-shift-alt-F1 to switch to a tty, and then ctrl-alt-del and the system reboots. I also tried booting in text only mode and manually doing echo mem > /sys/power/state, and still no video on resume. If I then blindly type vbetool post, the display comes on, but is all messed up since it is in the default VGA Text mode rather than the graphics mode that the console driver expects it to be in. This is all with the amd64 build using an ATI Radeon HD 4850. I can see nothing out of the ordinary when reviewing the syslog either; as far as the kernel is concerned, it thinks it resumed just fine.

Any pointers for further debugging are welcome.

Phillip Susi (psusi)
tags: added: regression-potential
Revision history for this message
Phillip Susi (psusi) wrote :

I have narrowed it down to the config setting CONFIG_PM_DISABLE_CONSOLE. The mainline kernel package does not have this option set, and the Ubuntu kernel does. When I build the Ubuntu 2.6.35 kernel sources with this setting, the problem occurs. When I build the sources with CONFIG_PM_DISABLE_CONSOLE=n, the problem goes away. Interestingly, this option is set in the Ubuntu Lucid 2.6.32 kernel and does not seem to cause a problem there.

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Hi Phillip,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 594885

Also, please be sure to take a look at . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Phillip Susi (psusi)
tags: removed: needs-upstream-testing
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hey Amit,

The CONFIG_PM_DISABLE_CONSOLE config option that Phillip notes in comment #2 seems to originate from the following Ubuntu SAUCE patch which you originally authored:

ogasawara@emiko:~/ubuntu-maverick$ git show 6063b4dc3721a63d70f81522fa130372ded60b45
commit 6063b4dc3721a63d70f81522fa130372ded60b45
Author: Amit Kucheria <email address hidden>
Date: Fri May 23 11:43:45 2008 +0300

    UBUNTU: SAUCE: pm: Config option to disable handling of console during suspend/resume

    Signed-off-by: Amit Kucheria <email address hidden>

    Signed-off-by: Ben Collins <email address hidden>

This patch seems quite old and I'm curious if it's still needed in Maverick. I'm inclined to drop it, given that it appears to now be causing issues for users like Phillip. Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: maverick
Changed in linux (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I posted this for discussion on the kernel-team mailing list. After discussion with Amit, I'll be dropping the patch noted in comment #3 from the Maverick kernel which should then resolve this issue. Thanks.

Changed in linux (Ubuntu):
milestone: none → maverick-alpha-2
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-5.6

linux (2.6.35-5.6) maverick; urgency=low

  [ Amit Kucheria ]

  * [Config] update omap flavour description

  [ Andy Whitcroft ]

  * update to ubuntu-debian:508b7aa34b578c0d1e51bfb571f2bfb824dc65ac
    - LP: #570500, #576274
  * SAUCE: add option to hand off all kernel parameters to init
    - LP: #586386
  * [Config] enable passing all kernel command line to init
    - LP: #586386
  * [Config] disable CONFIG_VMI
    - LP: #537601
  * [Config] enable CONFIG_IPV6_SIT_6RD
    - LP: #591869
  * [Config] enable CONFIG_VMWARE_BALOON as module
    - LP: #592039

  [ Leann Ogasawara ]

  * Revert "SAUCE: pm: Config option to disable handling of console during
    - LP: #594885
  * [Config] ports: enable passing all kernel command line to init
    - LP: #586386
  * [Config] Enable CONFIG_FB_VESA=y for x86
  * [Config] Add CONFIG_FRAMEBUFFER_CONSOLE=y to config enforcer
  * [Config] Add CONFIG_FB_VESA=y for x86 to config enforcer
  * [Config] Enable CONFIG_TASK_DELAY_ACCT=y
    - LP: #493156

  [ Mathieu Poirier ]

  * ARM: Adding MosChip MCS7830 to nic-usb
    - LP: #584920

  [ Upstream Kernel Changes ]

  * Revert "[Upstream] docbook: need xmldoclinks for all doc types"
  * docbook: need xmldoclinks for all doc types
  * perf probe: Add kernel source path option
 -- Leann Ogasawara <email address hidden> Thu, 17 Jun 2010 08:05:29 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.