PCM 100% is much higher than 0 dB for codec ssid 0x1631c20e

Bug #541802 reported by Valombre
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Daniel T Chen
Nominated for Karmic by Chris Wyatt
Fix Released

Bug Description

This bugfix has been part of the upstream stable update for Lucid to (see Bug #583414).


For my laptop specific sound card (see apport report), the sound is too high at first startup live cd and first boot, and the maximum limit is too high too.
I guess i could damage speakers and ears if i put maximum volume, and i won't try for my safety....
Normal use of sound is actually around 15% and maximum volume usable without damages 25%
As i have no control on the pcm stuff i can't adjust the amplifier stuff.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: valombre 1252 F.... pulseaudio
 Card hw:0 'Intel'/'HDA Intel at 0xf4600000 irq 22'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,1631c20e,00100100'
   Controls : 18
   Simple ctrls : 8
Date: Fri Mar 19 11:43:07 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: alsa-base
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: alsa-driver
Uname: Linux 2.6.32-16-generic x86_64

Revision history for this message
Valombre (valombre-d) wrote :
tags: added: iso-testing
Revision history for this message
Daniel T Chen (crimsun) wrote :

"Too high" is pretty subjective. There isn't anything misreported by your driver for dB information.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Revision history for this message
Valombre (valombre-d) wrote :

Oki, any clue how i could demonstrate the problem with logs or other ?
May be a video with sound of the startup sequence of the livecd would be efficient but i don't have actually the necessary recorder, i'll try to find one next week.
The only thing i could do actually is to use recordmydesktop and play with volume .. i give a try and post result.

Revision history for this message
Valombre (valombre-d) wrote :

I've done a record test with gtk-recordmydesktop and the result is available on google documents ogv format 4087 ko =>

Tell me if you need more infos.

Revision history for this message
Valombre (valombre-d) wrote :

Here a record with a cam of the startup sequence of the lucid live beta 1, and some demonstration playing with volume, the problem is clear, the scale volume isn't good.
File: avi format on google documents 27 Mo =>

I just ask for some more infos or solutions about this problem, mays be some file to modify to change the scale in pulseaudio to avoid an error of manipulation on putting the sound to high and damaging my laptop.

I tried on the lucid to install alsamixer gui to modify the PCM but pulseaudio keep control of the "global" volume.

Revision history for this message
Daniel T Chen (crimsun) wrote :

I can't view those or listen to them. Furthermore, to properly debug, you need to set all playback volumes to maximum (100%, whatever that means) and reattach output from 'amixer'.

summary: - Sound too high at startup (live cd and first boot) and max limit.
+ PCM 100% is much higher than 0 dB
Revision history for this message
Valombre (valombre-d) wrote : Re: PCM 100% is much higher than 0 dB

I used alsamixer in console to put everything at maximum volume and done a amixer > amixer.txt see attachment.

PS : If you need my videos in specific format just tell i use winff and ffmpeg libs for that.

Revision history for this message
Chris Wyatt (wyattmeister) wrote :

I have the same problem with what looks like a very similar chip, I would guess it's probably related:

Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
Conexant CX20551 (Waikiki)

Basically I get distortion on all volumes because PCM is always set to around 100% by ALSA.  I had this problem in Karmic as well.

I fixed it with a config tweak that I read on a Wiki somewhere, I can't find it at the moment otherwise I would share it here.

Revision history for this message
Valombre (valombre-d) wrote :

Still no solution, i re-install lucid on a new ssd disk, and try carefully to not put sound to high by mistake (around 15%).
If somebody find a link to a tweak to fix it i take ;)

Revision history for this message
Daniel T Chen (crimsun) wrote :

Chris, you have a different codec. Please file a separate bug report against alsa-driver.

summary: - PCM 100% is much higher than 0 dB
+ PCM 100% is much higher than 0 dB for codec ssid 0x1631c20e
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: Incomplete → Triaged
Daniel T Chen (crimsun)
Changed in alsa-driver (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
madbiologist (me-again) wrote :

The fix for this bug has been included upstream in kernel 2.6.34-rc7, and also cc'd to the stable kernel branch (meaning 2.6.33 and possibly 2.6.32). From the changelog:

commit 8f0f5ff6777104084b4b2e1ae079541c2a6ed6d9
Author: Daniel T Chen
Date: Wed Apr 28 18:00:11 2010 -0400

    ALSA: hda: Fix 0 dB for Packard Bell models using Conexant CX20549 (Venice)

    BugLink: https://launchpad.net/bugs/541802

    The OR's hardware distorts at PCM 100% because it does not correspond to
    0 dB. Fix this in patch_cxt5045() for all Packard Bell models.

    Reported-by: Valombre
    Cc: <email address hidden>
    Signed-off-by: Daniel T Chen
    Signed-off-by: Takashi Iwai

Revision history for this message
madbiologist (me-again) wrote :

Good news - the fix is being reviewed for kernel

Revision history for this message
Valombre (valombre-d) wrote :

Nice the kernel that i use on lucid is 2.6.32-22-generic i guess the numbers are quite different in Ubuntu, i'll wit for the next kernel update.
Thanks for the works done ;)

Stefan Bader (smb)
description: updated
Martin Pitt (pitti)
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
milestone: none → maverick-alpha-2
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (25.2 KiB)

This bug was fixed in the package linux - 2.6.32-23.37

linux (2.6.32-23.37) lucid-proposed; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms/atom: fix dual-link DVI on DCE3.2/4.0
    - LP: #564559

  [ Andy Whitcroft ]

  * [Config] ports -- build in dm-mod to enable LVM boot
    - LP: #560717
  * tools -- fix perf version extraction for multi-part flavours
    - LP: #555130
  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354
  * [Config] enforce -- ensure dm_mod is built-in for LVM
    - LP: #560717
  * update to ubuntu-debian:7e708d33054c373faf41da23b73e8b48c342d958
    - LP: #570500, #576274

  [ Chase Douglas ]

  * Revert "(pre-stable): input: ALPS - Add signature for HP Pavilion dm3
    - LP: #550625
  * Enable ftrace function profiler
    - LP: #570389
    - LP: #575940

  [ Leann Ogasawara ]

  * Revert "staging/comdi -- disable"
    - LP: #563436
  * [Config] Enable multicast routing for sparc
    - LP: #416266
  * [Config] Add ahci.ko to virtual sub-flavour
    - LP: #570542

  [ Stefan Bader ]

  * Revert "SAUCE: drm/i915: Disable FBC on 915GM and 945GM"
    - LP: #588832

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
  * [Config] Add atl1c to nic-modules udeb
    - LP: #557130

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) iwlwifi: fix nfreed--"
    - LP: #575853
  * Revert "backlight: mbp_nvidia_bl - add five more MacBook variants"
    - LP: #575853
  * Revert "(pre-stable) pata_via: Add VIA VX900 support"
    - LP: #575853
  * Revert "(pre-stable) x86-32, resume: do a global tlb flush in S4
    - LP: #575853
  * Revert "x86: disable IOMMUs on kernel crash"
    - LP: #575853
  * Revert "sunrpc: fix peername failed on closed listener"
    - LP: #575853
  * Revert "sunrpc: move the close processing after do recvfrom method"
    - LP: #575853
  * Revert "(pre-stable) drm/edid: allow certain bogus edids to hit a fixup
    path rather than fail"
    - LP: #575853
  * Revert "drm/radeon/kms: don't print error on -ERESTARTSYS."
    - LP: #575853
  * Revert "ath9k: fix lockdep warning when unloading module" on stable
    - LP: #588832
  * Staging: comedi: removed "depricated" from COMEDI_CB_BLOCK
    - LP: #483343
  * fat: fix buffer overflow in vfat_create_shortname()
    - LP: #575853
  * xfs: simplify inode teardown
    - LP: #575853
  * xfs: fix mmap_sem/iolock inversion in xfs_free_eofblocks
    - LP: #575853
  * xfs: I/O completion handlers must use NOFS allocations
    - LP: #575853
  * xfs: Wrapped journal record corruption on read at recovery
    - LP: #575853
  * xfs: Fix error return for fallocate() on XFS
    - LP: #575853
  * xfs: check for not fully initialized inodes in xfs_ireclaim
    - LP: #575853
  * xfs: fix timestamp handling in xfs_setattr
    - LP: #575853
  * xfs: Don't flush stale inodes
    - LP: #575853
  * xfs: Ensure we force all busy extents in range to disk
    - LP: #575853
  * xfs: reclaim inodes under a write lock
    - LP: #575853
  * xfs: Avoid inodes in reclaim when flushing from inode cache
    - LP: #575853
  * xfs: recla...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Valombre (valombre-d) wrote :

Well, the patch is working like a charm !
The sound volume is now correctly managed good work for everyone, thanks !

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.