linux-gcp 6.2.0-1017.19 source package in Ubuntu

Changelog

linux-gcp (6.2.0-1017.19) lunar; urgency=medium

  * lunar/linux-gcp: 6.2.0-1017.19 -proposed tracker (LP: #2038064)

  * CVE-2023-42755
    - [Config] remove NET_CLS_RSVP and NET_CLS_RSVP6

  * SEV_SNP failure to init (LP: #2037316)
    - x86/sev-es: Allow copy_from_kernel_nofault in earlier boot
    - x86/sev-es: Only set x86_virt_bits to correct value

  [ Ubuntu: 6.2.0-35.35 ]

  * lunar/linux: 6.2.0-35.35 -proposed tracker (LP: #2038229)
  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
  * CVE-2023-4244
    - netfilter: nf_tables: don't skip expired elements during walk
    - netfilter: nf_tables: integrate pipapo into commit protocol
    - netfilter: nft_set_rbtree: fix overlap expiration walk
    - netfilter: nf_tables: adapt set backend to use GC transaction API
    - netfilter: nft_set_hash: mark set element as dead when deleting from packet
      path
    - netfilter: nf_tables: drop map element references from preparation phase
    - netfilter: nf_tables: GC transaction API to avoid race with control plane
    - netfilter: nf_tables: remove busy mark and gc batch API
    - netfilter: nf_tables: don't fail inserts if duplicate has expired
    - netfilter: nf_tables: fix kdoc warnings after gc rework
    - netfilter: nf_tables: fix GC transaction races with netns and netlink event
      exit path
    - netfilter: nf_tables: GC transaction race with netns dismantle
    - netfilter: nf_tables: GC transaction race with abort path
    - netfilter: nf_tables: use correct lock to protect gc_list
    - netfilter: nf_tables: defer gc run if previous batch is still pending
    - netfilter: nft_dynset: disallow object maps
    - netfilter: nft_set_rbtree: skip sync GC for new elements in this transaction
  * CVE-2023-5197
    - netfilter: nf_tables: skip bound chain in netns release path
    - netfilter: nf_tables: disallow rule removal from chain binding
  * CVE-2023-4921
    - net: sched: sch_qfq: Fix UAF in qfq_dequeue()
  * CVE-2023-4881
    - netfilter: nftables: exthdr: fix 4-byte stack OOB write
  * CVE-2023-4623
    - net/sched: sch_hfsc: Ensure inner classes have fsc curve
  * CVE-2023-4622
    - af_unix: Fix null-ptr-deref in unix_stream_sendpage().
  * CVE-2023-42756
    - netfilter: ipset: Fix race between IPSET_CMD_CREATE and IPSET_CMD_SWAP
  * CVE-2023-42755
    - net/sched: Retire rsvp classifier
    - [Config] remove NET_CLS_RSVP and NET_CLS_RSVP6
  * CVE-2023-42753
    - netfilter: ipset: add the missing IP_SET_HASH_WITH_NET0 macro for
      ip_set_hash_netportnet.c
  * CVE-2023-42752
    - igmp: limit igmpv3_newpack() packet size to IP_MAX_MTU
    - net: add SKB_HEAD_ALIGN() helper
    - net: remove osize variable in __alloc_skb()
    - net: factorize code in kmalloc_reserve()
    - net: deal with integer overflows in kmalloc_reserve()
  * CVE-2023-34319
    - xen/netback: Fix buffer overrun triggered by unusual packet

 -- John Cabaj <email address hidden>  Thu, 05 Oct 2023 21:59:43 -0500

Upload details

Uploaded by:
John Cabaj
Uploaded to:
Lunar
Original maintainer:
Ubuntu Kernel Team
Architectures:
amd64 arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Lunar security main devel
Lunar updates main devel

Builds

Lunar: [FULLYBUILT] amd64 [FULLYBUILT] arm64

Downloads

File Size SHA-256 Checksum
linux-gcp_6.2.0.orig.tar.gz 208.4 MiB e25ae806476ae60671bedf91d5b120a75a27a8c9eb3355ed6c53edec6038eac3
linux-gcp_6.2.0-1017.19.diff.gz 7.0 MiB 7b91ec8404163d4c295792bcc7803aa697dac78acd6b56eec343746ae502a71b
linux-gcp_6.2.0-1017.19.dsc 4.3 KiB bab95dfeb3053f50e3b5f5870dca3ee8c641c3053922ac03b6cb3d3ed86951d7

View changes file

Binary packages built by this source

linux-buildinfo-6.2.0-1017-gcp: Linux kernel buildinfo for version 6.2.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 6.2.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-gcp-headers-6.2.0-1017: Header files related to Linux kernel version 6.2.0

 This package provides kernel header files for version 6.2.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-gcp-headers-6.2.0-1017/debian.README.gz for details

linux-gcp-tools-6.2.0-1017: Linux kernel version specific tools for version 6.2.0-1017

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 6.2.0-1017 on
 ARMv8.
 You probably want to install linux-tools-6.2.0-1017-<flavour>.

linux-headers-6.2.0-1017-gcp: Linux kernel headers for version 6.2.0 on ARMv8 SMP

 This package provides kernel header files for version 6.2.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-6.2.0-1017/debian.README.gz for details.

linux-image-unsigned-6.2.0-1017-gcp: Linux kernel image for version 6.2.0 on ARMv8 SMP

 This package contains the unsigned Linux kernel image for version 6.2.0 on
 ARMv8 SMP.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-6.2.0-1017-gcp-dbgsym: Linux kernel debug image for version 6.2.0 on ARMv8 SMP

 This package provides the unsigned kernel debug image for version 6.2.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-6.2.0-1017-gcp: Linux kernel extra modules for version 6.2.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-6.2.0-1017-gcp: Linux kernel extra modules for version 6.2.0 on ARMv8 SMP

 This package contains the Linux kernel extra modules for version 6.2.0 on
 ARMv8 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-iwlwifi-6.2.0-1017-gcp: Linux kernel iwlwifi modules for version 6.2.0-1017

 This package provides the Linux kernel iwlwifi modules for version
 6.2.0-1017.
 .
 You likely do not want to install this package directly. Instead, install the
 one of the linux-modules-iwlwifi-gcp* meta-packages,
 which will ensure that upgrades work correctly, and that supporting packages are
 also installed.

linux-tools-6.2.0-1017-gcp: Linux kernel version specific tools for version 6.2.0-1017

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 6.2.0-1017 on
 ARMv8.