docker containers doesn't work; dropped SSH connection

Bug #1977978 reported by Oleg Konobeev
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-gcp (Ubuntu)

Bug Description

The problem affecting at least Ubuntu 20.04.

After last kernel update to

~# uname -a
Linux hostname 5.13.0-1030-gcp #36~20.04.1-Ubuntu SMP Fri Jun 3 15:33:42 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Docker stopped working normally.

For example, trying to start simple Grafana container:
~# docker run -d -p 3000:3000 grafana/grafana
root@hostname:~# client_loop: send disconnect: Broken pipe

After trying to start docker-container also SSH connection are dropped.
And unfortunately container doesn't start at all.

Tried to use older docker-ce versions but the same result.
Only one thing cures that behavior, dropping kernel version to
Linux hostname 5.13.0-1027-gcp #32~20.04.1-Ubuntu SMP Thu May 26 10:53:08 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Also found the same problems with a different docker-images.

docker-ce version:
Docker version 20.10.17, build 100c701

And `docker info` (just in case)
 Context: default
 Debug Mode: false
  app: Docker App (Docker Inc., v0.9.1-beta3)
  buildx: Docker Buildx (Docker Inc., v0.8.2-docker)
  scan: Docker Scan (Docker Inc., v0.17.0)

 Server Version: 20.10.17
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
  userxattr: false
 Logging Driver: journald
 Cgroup Driver: cgroupfs
 Cgroup Version: 1
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 10c12954828e7c7c9b6e0ea9b0c02b01407d3ae1
 runc version: v1.1.2-0-ga916309
 init version: de40ad0
 Security Options:
   Profile: default
 Kernel Version: 5.13.0-1030-gcp
 Operating System: Ubuntu 20.04.4 LTS
 OSType: linux
 Architecture: x86_64
 CPUs: 2
 Total Memory: 7.763GiB
 Name: hostname
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Username: user
 Experimental: true
 Insecure Registries:
 Live Restore Enabled: false

Oleg Konobeev (choooze)
description: updated
Oleg Konobeev (choooze)
description: updated
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-gcp (Ubuntu):
status: New → Confirmed
Oleg Konobeev (choooze)
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.