March 8 2007 updates caused EPSOn CX6400 to not be recognised

Bug #90724 reported by cristian
Affects Status Importance Assigned to Milestone
libgphoto2 (Ubuntu)
Fix Released
Colin Watson

Bug Description

Late 7th March used printer no problems. This morning did software updates for Ubuntu Edgy and since then my printer no longer works. IN cups print manager (localhost:631) I used to be able to see the URI as a USB address. Now the printer port is no longer recognised at all. I think I set it up originally under LPT #1 but this has now disappeared.

Can I undo the updates of 8 March

Please help.


Revision history for this message
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add your '/etc/cups/printers.conf' configuration file to your bug report as an attachment? Thanks in advance.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Can you please post the output of the commands

lpinfo -v
ls -l /usr/share/cups/backend
sudo usb_printerid /dev/usblp0
sudo usb_printerid /dev/usblp1
grep -A4 cupsys/backend /var/cache/debconf/config.dat

and the file


Revision history for this message
Martin Lubich (mlubich) wrote :

I had the same problem with my Samsung ML-1520 usb printer after updating.

I think I found the reason for this problem.
Here is my analysis:

The backported libgphoto2 package installs a new udev rule file. Where previously SYSFS{...} was used to match against attributes now ATTRS{...} is employed.
This is a syntax which the udev version in egdy does not recognize. My guess here (as I do not have feisty installed ) is that feisty is using a newer udev version. The udev man page under edgy does not mention any ATTRS for its syntax in rule files.

This wrong syntax now causes udev to create a device file with the wrong ownership set, specifically group ownership of plugdev. This seems to be true for any plugged in device, whose vendorid happens to be preset in the libgphoto rule file. For pinters this leads to a device entry /dev/usblpxx with group ownership set to plugdev.

Since the cups system operates in group lp cups is no longer able to acces the printer device, hence no printing is possible.

Since it is sufficient, that only the vendorid has to have a match in the libgphoto rule file, this problem should affect any usb printer whose vendor also sells cameras, which is true for a lot of brands (canon, hp, epson, minolta, samsung ...). So this should be a widely spread problem. A look at recent posts in the ubuntu forums confirms this assumption.

Essentially the backport update rendered the printing system unusable.

I was able to workaround this problem by replacing all occurances of ATTRS with SYSFS in the libgphoto rule file.


Changed in cupsys:
importance: Undecided → High
status: Needs Info → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

So it seems that on the libgohoto2 update it was not taken into account that UDEV had incompatible changes from Edgy to Feisty. So the libgphoto2 update for Edgy needs to be fixed.

Easiest workaround until release of the fix: Add user "cupsys" to group "plugdev" in /etc/group.

Changed in libgphoto2:
assignee: brian-murray → nobody
Revision history for this message
Pascal De Vuyst (pascal-devuyst) wrote :

Subscribing John Dong.

libgphoto2 (2.3.0-0ubuntu3~edgy1) edgy-backports; urgency=low

  * Automated backport upload; no source changes.

 -- John Dong <email address hidden> Wed, 7 Mar 2007 23:18:29 +0000

Revision history for this message
John Dong (jdong) wrote :

I'm working on a fix for that as we speak.

Revision history for this message
John Dong (jdong) wrote :

The attached debdiff fixes this bug, please sponsor into edgy-backports

Revision history for this message
JohnH (johnandangie) wrote :

Yep, same problem.

I have a USB Kyocera FS-1010. Worked fine. It is a very Linux friendly printer. Now it doesn't work. Did an update on my other laptop "after" I performed a successful test print. It does not work now either. It is a local printer but is no longer recognised as such.

printers.conf file:

# Printer configuration file for CUPS v1.2.4
# Written by cupsd on 2007-03-10 00:12
<Printer fs1010>
Info Kyocera Mita FS-1010
DeviceURI ipp://usb://Kyocera/FS-1010
State Idle
StateTime 1173446929
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job

Best regards

Revision history for this message
Colin Watson (cjwatson) wrote :

OK, I went with a slightly different fix after talking further with jdong. Until builds of this reach the archive, you can run the following command to fix the problem, which is equivalent to this upload:

  sudo sh -c '/usr/lib/libgphoto2/print-camera-list udev-rules mode 0660 group plugdev > /etc/udev/rules.d/45-libgphoto2.rules'

libgphoto2 (2.3.0-0ubuntu3~edgy2) edgy-backports; urgency=low

  * Generate pre-0.98 udev rules (LP: #90724).

 -- Colin Watson <email address hidden> Fri, 9 Mar 2007 22:53:35 +0000

Changed in libgphoto2:
assignee: nobody → kamion
status: Confirmed → Fix Released
Revision history for this message
cristian (ccm7800) wrote :

Thanks to everyone for replying. I went on holiday the day after posting this bug. In the end, I found a workaround on the forums changing the ownership of the device on a singular basis to then worked like a treat. When the update is fixed can I just install this automatically?

Many thanks


To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.