plasma-panel and window-decorations not transparent

Bug #652863 reported by kramerstefan
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)

Bug Description

Description: Ubuntu maverick (development branch)
Release: 10.10

Just upgraded Kubuntu to Maverick RC & can't seem to get transparent plasma panel. Also the window decorations and menus are not transparent any more.
What seems quite strange is that when I click the panel's cashew the drop down menu is transparent for a second before it also looses transparency.

Under Lucid with KDE SC 4.5.1, I just had transparent panel, menu, window decoration.

My graphics card according to lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Tags: kde maverick
Revision history for this message
kramerstefan (kramerstefan-web) wrote :
Revision history for this message
dan.boff (dan-boff) wrote :

same here with Maverick RC: I upgraded to maverick yesterday. The bug does not appear when i'm using kubuntus livecd. Also transparence was working yesterday, so I guess an upgrade is to blame for it

y graphics card according to lspci:
02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]

I tried with the open source driver and fglrx: transparent plasma panel + decorations are not working with either of them

affects: ubuntu → kdebase (Ubuntu)
Revision history for this message
Åke Svedin (belse) wrote :

Same here. Never ran lucid. But I did not experience this bug the first boot directly after a clean install from the Maverick Kubuntu DVD. I have a laptop with switchable graphics (Intel + ATI), but I quickly disabled the discrete card and blacklisted the driver. I also upgraded to KDE 4.5.4 from kubuntu-ppa. The next boot, I had this bug! Hmm.. I also added an option "acpi_osi=Linux" to grub, but that was later, should be unrelated.

I've tried the following (in this order):
1) Delete ~/.kde directory and log in again.
2) Downgrading to non-ppa KDE.
3) Trying out Gnome which did not show any sort of rendering bugs.
4) Upgrading intel driver (ppa:ubuntu-x-swat/x-updates and ppa:xorg-edgers/ppa)
5) Upgrading to KDE 4.6 Beta 2 via kubuntu beta ppa.

I did not try to enabled the discrete adapter.

Kwin settings:
OpenGL (and all defaults) = This bug
OpenGL w/o blur effect = The kickoff menu, notifications and bar are transparent! but way too transparent. Text in notifications become very hard to read.
The setting "Transparency" does only affect window transparency, which works fine anyway.
XRender = Seems to work fine.
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile GEM 20100330 DEVELOPMENT
OpenGL version string: 2.1 Mesa 7.10-devel

lsmod | grep video
uvcvideo 62379 0
videodev 49359 1 uvcvideo
v4l1_compat 15519 2 uvcvideo,videodev
v4l2_compat_ioctl32 12486 1 videodev
video 22176 1 i915
output 2527 1 video

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
02:00.0 VGA compatible controller: ATI Technologies Inc Redwood [Radeon HD 5600 Series] (rev ff)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: kdebase (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.