touchscreen does not tap - sometimes

Bug #1162216 reported by foggydude
This bug affects 22 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)

Bug Description

in plasma, the touchscreen stops tapping. so, you can move the pointer and hover items, but not click them. ie, tapping the launcher, i get the information popup or tapping an item in the task manager, i get a preview of that screen but cant activate it.

it also happens in a few apps, like rekonq. the windowmanager also works (i can move, resize and close windows, also if their content is not responsive.

funny detail: the kicker and panel toolbox - if opened with the touchpad, do work. ie once opened, i can select apps from the kicker.

hardware: asus x202e

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: plasma-desktop 4:4.10.1b-0ubuntu5
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Uname: Linux 3.8.0-15-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Sat Mar 30 14:35:13 2013
InstallationDate: Installed on 2013-03-28 (2 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
 PATH=(custom, no user)
SourcePackage: kde-workspace
UpgradeStatus: Upgraded to raring on 2013-03-30 (0 days ago)

Revision history for this message
foggydude (rogier-stekje) wrote :
Revision history for this message
link (nikarul) wrote :

I'm having similiar issues with a fresh install of 13.04 armhf on my Beagleboard XM. LightDM, the kicker and settings windows will respond to taps but the main screen seems completely unresponsive to any taps.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael D. Stemle, Jr. (manchicken) wrote :

Same problem on amd64 with ASUS Q200E. Touchscreen works just fine in applications and even Unity, but in the panel it won't actually click things.

Revision history for this message
eCaravanier (ecaravanier) wrote :

Same problem here on Ubuntu 13.04 64bits on a Lenovo Yoga 13.

Revision history for this message
MoGa (mr-3sool) wrote :

I noticed that when I unlock and lock widget and touch-to-click any of the widget on desktop I lose the ability to touch-to-click any item on the panel except for the system try icons which are clickable through touching.

The mouse clicks are fine.

Revision history for this message
Rohan Garg (rohangarg) wrote :

Thanks for taking the time to report this bug. 13.04 reached EOL on January 27, 2014.
Please see this document for currently supported Kubuntu releases:

Unfortunately this means that there will be no more bugfixes for 13.04. It is also recommended that you upgrade, if you have not already.

Please feel free to report any other bugs you may find, and thanks for your understanding.

Changed in kde-workspace (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
MoGa (mr-3sool) wrote :

This affects newer version as well.

Changed in kde-workspace (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Abhijit Bhopatkar - BAIN (bain-devslashzero) wrote :

This is affecting 3.10 kde 4.12 as well. Makes touchscreen almost useless.

Revision history for this message
Charl (78luphr0rnk2nuqimstywepozxn9kl19tqh0tx66b5dki1xxsh5mkz9gl21a5rlwfnr8jn6ln0m3jxne2k9x1ohg85w3-launchpad) wrote :

I can confirm that this is still an issue in KDE 4.13.0 on Linux 3.13.0-24 amd64.

Touchscreen tap-to-click works fine in most applications, e.g. FireFox, Dolphin. Tapping widgets/panels seems to register, e.g. in Application Launcher it outlines the program in the list that was tapped, but it does not register as an actual click action, i.e. the program is not actually launched.

Revision history for this message
Stefano Forli (ntropia) wrote :

Confirmed on 4.13.1, Kubuntu 14.04 LTS.
Actions that are affected are:
-two-finger scrolling
-tap to click
-tap and drag.

Revision history for this message
MoGa (mr-3sool) wrote :

Please provide any noticeable actions that lead to this behaviour.
In my case, touch functionality is fine until i tap desktop's widgets. This seems to triger the hover pointer instead of pointer with click ability.

Revision history for this message
Stefano Forli (ntropia) wrote :

I spent some time during the weekend to trace the the problem, and I found what looks like a working solution at least for me. Below some more details.

My laptop is an Asus Zenbook UX31A with Elantech touchpad.
It used to work fine with 13.10, but after the update to 14.04, I had no way to use the tap at all. The two-finger scrolling didn't work all the time.

1. Xinput reported the tap to be properly configured, so I've used "set-prop" to disable and re-enable it, again, no success.
Tpconfig (tpconfig --tapmode=1) wasn't even able to set the tap value properly. The command "mev" didn't report the tap event, while others (two-finger, actual clicks) were recognized.

2. Using a freshly created account, I found that it was working fine with that user, so I did a systematic analysis of all the
I traced the problem to the existence of two different config files for touchpad settings (likely, one of them was created after the update):


I think they correspond to the two startup services I see (Settings->Startup and Shutdown->Service Manager), namely "KDE Touchpad Enabler daemon" and "Touchpad". I would say the former should be the one to keep, but I'm not sure about it.

1. I've removed the two config files and I re-configured the touchpad using the Settings interface and I've restored the tap.

2. Surprisingly, the tap stopped working again when the palm recognition was activated, while everything else worked fine so keep an eye on that too.

As far as I can tell, this restored the full functionality on my system, but palm detection must be disabled.

Revision history for this message
Jiří Babocký (jurasb) wrote :

I can confirm this bug on Toshiba satelite u920t. It seems to be related to some plasma widgets. How to reproduce:
- Change menu to classic (it makes this bug to happen unpredictably)
- add any plasmoid on desktop
- logout/login
- touchscreen will work until you touch plasmoid on desktop
- restart plasma-desktop (killall plasma-desktop, plasma-desktop)
- touchscreen works again
- doesn't happen if you touch plasmoid, that is set as desktop background (folderview, etc.)

Revision history for this message
Jiří Babocký (jurasb) wrote :

have a look at debian sources, this bug affects only ubuntu based distros, touchscreen works fine everywhere else (debian, fedora, mageia, ...), syncing the code with debian jessie should resolve it

Revision history for this message
v4nadium (v4nadium) wrote :

I confirm this bug on Asus N550IJ, Kubuntu 14.04 freshly installed. Two-finger plasmoid resizing works perfectly fine but I cannot tap plasmoids, launcher, etc.

Revision history for this message
Tim Edwards (tkedwards) wrote :

Confirmed this bug on a Lenovo Yoga 2 Pro with Kubuntu 14.04

Revision history for this message
Marc Salat (marcs14) wrote :

Confirmed this bug in Kubuntu 14.10... so sad :(
Hard: ExoPC

Revision history for this message
Marc Salat (marcs14) wrote :

Happens in Archlinux also, must be a KDE related bug.

Revision history for this message
MoGa (mr-3sool) wrote :

Can someone volunteer to try KDE 5 to see if it was fixed?

Revision history for this message
Marc Salat (marcs14) wrote :

No issues in Debian Jessie for 2 days
KDE 4.14.1
Hard: Exopc
Default installation x86

Revision history for this message
kinta (kinta-communia) wrote :

Same on plasma 5, as you can in attachment, tapping buttons with touchscreen has the same effect as touchpad hovering. Running touchegg is a workaround ( not a solution, as then it inherits all touchegg's issues) to get taps working again.

Revision history for this message
Sajjad Siddiqi (siddiqi-sajjad) wrote :

Confirmed on Dell Inspiron 11 convertible touch screen laptop with kubuntu 14.10. It happens as follows:
Touch screen stops tapping on the Desktop after you add a widget on the desktop. Removing the widget does not help either.

Revision history for this message
Elionai (elionai5683) wrote :

Can confirm this on a Lenovo S400 touch running Kubuntu 12.04 up to 14.04. I cannot work with widgets or my single tap on touchscreen will register as hover. Single taps will still work in some applications, but not on panel. Also, since 12.04, most dropdown menus never work with the touchscreen. If they appear at all, they disappear immediatly. After upgrade last night which updated chrome and firefox, I now have occasional issues with the single tap function in my browsers. When I launch Firefox, the single tap becomes hover (sometimes) and doesn't return for some time. During that time, it affects the whole system.

Please note I have installed touchegg and have found that, while it adds the ability to customize gestures, it does absolutely nothing to help any of these issues. The problem remains even when using xinput to calibrate.

I praise the Linux communites all the time for their timely response in updating with fixes to bugs like these, and I rarely complain about Linux bugs, because I understand that, in using Kubuntu, I am recieving something awesome at no cost! However, as the size of this thread indicates, these touchscreen bugs are a nuisance, and have been present and reproducible in Kubuntu since at least 12.04. And as someone mentioned above, they are still present in KDE 5. This issue has been a longstanding thorn in Kubuntu's side, and in the sides of its users. It's time to address it, or at least tell us that it's being addressed. Sorry, I appreciate this community, but I don't understand why KDE 5 is a focus when important issues like this haven't been addressed since at least 2012. Priorities seem skewed here.

Revision history for this message
Nathaniel Eliot (temujin9) wrote :

Fresh install of Kubuntu 14.10 on a Dell Latitude E7240. Screen registers clicks and drags via the Touchpad settings, other KDE components, and Firefox, but fails to register clicks on Google Chrome.

Revision history for this message
Catscrash (catscrash) wrote :

still the same, anyone have any news?

Revision history for this message
Marian Klein (sandokan9) wrote :

still problem exist with kubuntu 19.04/disco in May 2019. This is a shame.
There are plenty of convertable devices laptop/tablet on the market.
HP spectre x360 Convertible. model 13-ae053na.

Touchscreen hover is not the same as touchpad hover. Has different action associated in plasma.

Hovering over an icon gets the focus of the icon for a touchpad , but not with a touchscreen.
With the focus on the icon the click or double click work for a touchpad.
To test: I can always trigger a tap/single click/double click on touchscreen , when previously hovering with touchpad over the icon. I always open/launch the icon like that.

Revision history for this message
pieter k (pieterkristensen) wrote :

I am using Kubuntu 22.04 and I have the same experience. It is always the same: when I start the machine it's fine. But after one- or a few minutes tap-to-click crashes.
I recently discovered that I can bring tap-to-click back to life again by touching the touchscreen with my finger (try to start an app etc). Within a few seconds tap-to-click starts working again. And it often stays running very long.
It feels as if two processes are hindering each other or so. And when that is over there are not so much problems anymore.
I use the backports ppa and the plasma 5.25 beta ppa in the hope that the touchscreen would behave better that way, but it isn't.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.