IBus does not support certain keyboard layouts

Bug #1284635 reported by Elfy
This bug affects 65 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Aron Xu
Aron Xu

Bug Description

installed trusty beta1 with keyboard layout set correctly during install

install completes, login to new install - layout as set during install

once logged in - layout set to US and keyboard layout set during install is missing from list

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: keyboard-configuration 1.70ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CurrentDesktop: XFCE
Date: Tue Feb 25 12:55:56 2014
InstallationDate: Installed on 2014-02-25 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140225)
PackageArchitecture: all
SourcePackage: console-setup
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Elfy (elfy) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Revision history for this message
Elfy (elfy) wrote :

greeter and keyboard layout screenshots attached

Revision history for this message
Elfy (elfy) wrote :
Revision history for this message
Elfy (elfy) wrote :

hob@hob-F71IX1:~$ locale
hob@hob-F71IX1:~$ echo $LANG

regardless of which - keyboard is in US layout

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu):
status: New → Confirmed
Changed in console-setup (Ubuntu):
importance: Undecided → High
Revision history for this message
Brian Murray (brian-murray) wrote :

I've been unable to recreate this bug. Did you choose the keyboard layout during the install process or did you change the language on boot up? Did choose to install packages from the internet or not during the install process?

Changed in console-setup (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Elfy (elfy) wrote :

I did nothing that I wouldn't normally do. I never choose to install during install.

I'll have another go today and report back.

Revision history for this message
Elfy (elfy) wrote :


During install I note that the keyboard selection stage - picks US - previously it would pick UK, select UK, test and proceed. Chose password to include #.

Install completes - rebooted to new install.

Logs in.

Using exactly the same password to run sudo apt-get update gets me a fail. Attached 2 screenshots.

I've not though tested this in anything other than Xubuntu.

Revision history for this message
Elfy (elfy) wrote :

Keyboard layout shown in settings manager, changing keyboard to UK as used during install obviously lets apt-get update now

Revision history for this message
Elfy (elfy) wrote :

Installed Ubuntu Daily.

Worked OK once logged in.

Revision history for this message
Elfy (elfy) wrote :

Same issue in Lubuntu

Revision history for this message
Elfy (elfy) wrote :

Same issue in UbuntuStudio

Revision history for this message
Elfy (elfy) wrote :

Doesn't affect Kubuntu.

Revision history for this message
Elfy (elfy) wrote :

Purging ibus fixes this in Xubuntu

Elfy (elfy)
Changed in console-setup (Ubuntu):
status: Incomplete → Confirmed
affects: console-setup (Ubuntu) → ibus (Ubuntu)
Revision history for this message
Woody (dave-woodwardmail) wrote :

I can confirm I have the same problem.

It seems that it may be down to console-setup not being installed, but when trying to install I get:
dwoodwar@hp-laptop:~$ sudo apt-get install console-setup
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 console-setup : Depends: keyboard-configuration but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Revision history for this message
intherye (intherye) wrote :

Same problem here: During install I chose language English and keyboard layout German. After login Ibus selects en_US, de is not configured.

@comment #16: on my fresh install console-setup was installed, so I can't confirm this.

Revision history for this message
Elfy (elfy) wrote :



Can you confirm that removing ibus stops the issue?

I'm not sure this bug is anything to do with console-setup

Revision history for this message
Woody (dave-woodwardmail) wrote :

I seem to have had 2 separate issues with the keyboard.

The first being the text console was using US Keyboard settings rather than UK. I think this may be related to console-setup not being able to be installed. I installed the Mar 16 2014 daily xubuntu snapshot into virtual box, and can confirm that console-setup was installed and keyboard appears to function as expected.

Second issue was incorrect keyboard settings in X11. Should be UK but appear to run as US. I seemed to find 2 seperate workarounds for this.

1) from terminal run
  sudo apt-get remove ibus
iBus appears to be some kind of new input device manager. I assume this is not yet configured to learn the installed language.

2) Configure iBus
Right click the iBus / Keyboard indicator in the notification area, and select preferences.
Click Input Method tab
Click customise active input methods
Click select an input method drop down, and choose English -> English (UK, extgended WinKeys)
Click Add
Close windows
Logout / Login or restart the ibus indicator

Hope this helps


Revision history for this message
Dan Chapman  (dpniel) wrote :

I can confirm this is also happening for me,

I set UK during install and after login keyboard settings are set to US and UK is not even available

tags: added: rls-t-tracking
Changed in ibus (Ubuntu Trusty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Hey Aron, could you have a look? Some people state it's an ibus regression with the most recent upstream version.

That seems to not impact Unity sessions, not sure why, so it's probably to test in e.g xfce.

Changed in ibus (Ubuntu Trusty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Aron Xu (happyaron)
Aron Xu (happyaron)
Changed in ibus (Ubuntu Trusty):
status: Confirmed → Triaged
Revision history for this message
Rolf Leggewie (r0lf) wrote :

I reported a similar problem in bug 1302353 but it only started two days ago after upgrading a bunch of unity packages.

summary: - Keyboard layout changes after login
+ ibus does not support certain keyboard layouts
Revision history for this message
Thaddaeus Tintenfisch (thad-fisch-deactivatedaccount) wrote :

Some more information about missing keyboard layouts in ibus:


Revision history for this message
Janne Uusitalo (janne-uusitalo-gmail) wrote :

Upgrading from 13.10 to 14.04 reset my formerly Finnish keyboard layout (supposedly into US, based on the comments above — the ö key threw apostrophes and the ä key semicolons). To restore it, I

1) opened up "Input Method", a dialog window titled "Input Method Configuration (im-config, ver. 0.24-1ubuntu3)",
2) failed to understand what the long and technical message* was trying to say, and just clicked "OK",
3) bravely answered "Yes" to the next question although it was not the recommended option,
4) selected "none" in a menu where "ibus" was selected (and probably clicked "OK" or something to confirm it**),
5) logged out and then logged back in.

*"Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing. Available input methods: ibus xim. Unless you really need them all, please make sure to install only one input method tool." Not very helpful advice to a regular user.

**I can't repeat the final step right now: the view where I changed "ibus" into "none" yesterday is broken today (a screenshot is attached).

Pasi Lallinaho (knome)
summary: - ibus does not support certain keyboard layouts
+ IBus does not support certain keyboard layouts
Revision history for this message
George Miles (dicegeorge) wrote :

I can install a UK keyboard from a login
and it then works aftyer reboot,
but the guest account is still US keyboard
so @ and £ are wrong.


•Lubuntu14.04 keyboard change from US default…
 1.click the US icon bottom right
2.this opens [Keyboard Layout Handler]
3.unselect [Keep system layouts]
4.at [Keyboard Layouts] click [+Add]
5.choose [gb English (UK)]
6.select [gb]
7.then click [Up]
8.click [Close]
9.This works for the user, and remains the setting after a reboot,

•But unfortunately the Guest Logon still has american keyboard, no £ sign and @ in the wrong place.

Revision history for this message
Branimir Butorac (branimir-butorac) wrote :

In Lubuntu just go to "Preferences → Language Suport" and on "Language" tab set "Keyboard input method system" to "none".

Solves the problem for me.

P.S. Croatian keyboard.

Revision history for this message
Branimir Butorac (branimir-butorac) wrote :

Forgot to say to close the iBus or restart your computer.

Revision history for this message
Stéphane Gourichon (stephane-gourichon-lpad) wrote :

Hello all,

Similar problem here.

## Problem description

Lubuntu 14.04 installed from beta (or daily).
Selected french keyboard.

Keyboard ok before login, every time (after boot or logout).

Logging in using lubuntu-notebook session.
After login, us keyboard is active instead of french.

## Workaround

In the menus I found a session-specific tool that allows to set french keyboard. It displayed a flag or country indicator in the notification area. That worked for days then suddenly the tool was no longer to be found and the us layout went back.

Then found this bug report. Applied sudo apt-get remove ibus. Log out, then log in.
Now have system-wide french keyboard work correctly after login.

## Warning

It appears tha

Revision history for this message
Stéphane Gourichon (stephane-gourichon-lpad) wrote :

Whoops, my message was posted too early. Continuing.

## Warning for lubuntu users.

It appears that ibus is required by lubuntu-desktop, which makes the problem only more present and increases impact of the workaround.

Indeed removal of ibus removes lubuntu-desktop which in turn makes some other programs ready to disappear.

Here's what apt-get log displayed (in French, but should be clear to apt-get user of any language):

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  blueman gdebi gdebi-core gnome-disk-utility language-selector-gnome libwhoopsie0 lubuntu-default-session lxsession-default-apps whoopsie
  xfce4-power-manager xfce4-power-manager-data
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  ibus ibus-pinyin ibus-table lubuntu-desktop
0 mis à jour, 0 nouvellement installés, 4 à enlever et 4 non mis à jour.
Après cette opération, 3 460 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n]

## Conclusion

I would rate this bug with severity relatively high, especially on lubuntu.
It probably hurts many users around the world, especially lubuntu users.
Can things be arranged so that a regular package update fixes that nasty bug ?

Thank you for your attention.

Revision history for this message
I Alejandro Fleischer (iafleischer) wrote :

I can't stop or modify receiving mails from this bug. Could you please help

Revision history for this message
Elfy (elfy) wrote :

@iafleischer - you can edit bug mail from the options near the top right of the page

Revision history for this message
rairlie (richwrd) wrote :

I experienced this problem on a new install of Ubuntu 14.04. I selected UK locale settings during installation, and the keyboard worked fine with the GB layout. Some time later after rebooting the keyboard was stuck on the US keymap, even though the menu bar showed "English (UK)" as selected.

My girlfriend experienced the same problem on her machine after upgrading from 13.10 to 14.04.

In case it's related, both machines use gnome shell as the desktop environment. The problem occurs when logging into either gnome shell or unity.

## Work around steps

1) Open a terminal and run: ibus-setup
2) Go to "Input Method" tab, click "Customise active input methods", remove the "English (US)" entry and add your keyboard - e.g. in my case "English (UK, extended WinKeys)".
3) Reboot

This retains the keyboard mapping so long as you leave it be... If you mess with the keyboard GUIs then "English (US)" comes back and becomes the default again.

As others have mentioned, running setxkbmap gb also works.

Revision history for this message
us2000 (q-launchpad-r) wrote :

ibus problem affects also users of chromium-browser 34.0.1847.116-0ubuntu2.

No keyboard input is possible in Chromium, until you apply one of the workarounds above.

Revision history for this message
us2000 (q-launchpad-r) wrote :
Revision history for this message
Elfy (elfy) wrote :

This awful thing got reinstalled on a system update and upgrade in Xubuntu - leaving me yet again with a keyboard layout that is of absolutely no use to me at all.

Why did it get reinstalled with a system update?

Why is it getting upgraded without any change to it's behaviour - is anyone actually taking any notice of the fact that it doesn't work?

Revision history for this message
Torsten Bronger (bronger) wrote :

I currently apply the workaround to right-click on this keyboard icon in the panel and click on "quit". I think this is the "purging ibus" thing, right?

Anyway, my --for me-- important question is: Is this purging of ibus responsible for xfce freezing every other day? It doesn't happen frequently but it means that I lose all running applications and have to restart lxsession.

Revision history for this message
Arthur (iegik) wrote :

iBus is working by switching layouts manually, from keyboard indicator icon on the panel, but cannot handle keyboard shortcuts, such as "Alt+Shift" or "Ctrl+Shift", when I try to configure it. "<Control>space", which is by default - also not work.

Revision history for this message
Dave Melia (retrospock) wrote :

Also affecting me -- Fresh install of Ubuntu 14.04 and installed XFCE to remote from Windows. Everything is set to EN-GB but keyboard is stuck in US.

Revision history for this message
ari (ari-henry) wrote :

Did sudo apt-get purge ibus
Removed a total of three ibus packages.
Logged out and in, still US keyboard.
Did an edit of keyboard layout and closed Settings panel. Re-opened Settings panel, edit keyboard layout back to UK with win keys. Log out log in and have a UK keyboard

Revision history for this message
Jamie (agent-ryan) wrote :

"Branimir Butorac (branimir-butorac) wrote on 2014-04-26: #26
In Lubuntu just go to "Preferences → Language Suport" and on "Language" tab set "Keyboard input method system" to "none".

Then reboot system

Solves the problem for me.

P.S. Croatian keyboard."

This also worked for me on Lubuntu.....GB keyboard....cheers Branimir Butorac :D

Revision history for this message
spyros (ospyros) wrote :

Hi this is also started happening to me a couple weeks ago after an update. Ubuntu 14.4 LTS on a Dell Latitude E6500.

Revision history for this message
bapoumba (bapoumba) wrote :

2 fresh installs of lubuntu Trusty daily and lubuntu Utopic daily on a desktop and a laptop respectively with azerty keyboards.

Both installs done twice with the following conditions :

- English language selected in the installer > qwerty keyboards during the install and after rebooting at the end of the install. Only installing the French language packs allow to choose azerty keyboards. iBus not removed or not exited.
- French language selected in the installer > azerty keyboards during the install procedure and after rebooting at the end of the install.

The installer should ask for both the environment language AND the keyboard layout when English is selected. Some users are experimenting difficulties entering the wifi passphrase during the install procedure due to improper keyboard layout (using ethernet here for installs). Many users use English interfaces with keyboards that are not of a US layout.

Revision history for this message
Torsten Bronger (bronger) wrote :

I'd like to add that, apart from the fact that keyboard inputs in Chromium don't work, I cannot have a "no dead keys" configuration due to this bug, i.e. I have to hit the accent keys twice to see the character.

Revision history for this message
Andrew Morris (zaglabod) wrote :

I may be a tad late in posting this, having only just found this bug report (25-Sep-14), but I fixed this situation in Lubuntu 14.04 on a first install just after it was released.
Go to:
Preferences>Keyboard Input Methods>Advanced
and under "Keyboard Layout" tick the "Use system keyboard layout" box. Then log out and back in.
"Keyboard Input Methods" menus are actually titled "IBus Preferences", so presumably are designed to control IBus.
What you will now see on the Task Bar is the code ID for your chosen system keyboard plus an adjacent small keyboard symbol which is the selector for the default US keyboard layout. There is a tab in the KIM for "Input Method" and from the wording at the bottom of the screen I presume that other keyboard layouts can be specified in this menu, which will then appear in the Task Bar selector (don't quote me, I haven't tried anything in this yet).

Revision history for this message
antonioni (antonioni-rocha) wrote :

The problem here: my layout is brazilian portuguese, it's shown in the desktop. But sometimes I start the system and the layout keeps typing in English, although the "Portuguese" layout is enabled.

Revision history for this message
Coeur Noir (coeur-noir) wrote :

On a fresh Lubuntu 14.04 install'

Fr_fr is my locale(s)

I aim to use Français(variante) keyboard.

I did choose these during installation from mini.iso with online updates.

It works as expected most of the time.

But sometimes on the login-greeter screen although FR is mentioned on the right of the panel it seems I have a US keyboard running - my password containing "@" and ":" and "numbers" I'm then lost !

Some other times it's in the expected french variant keyboard, but once logged into the desktop, it's then US keyboard…

Some other times it all looks as expected but when I try to use remote-desktop (reminna/vino or -sorry- TeamViewer) to reach that Lubuntu computer, I have no num-keypad and once again the keyboard looks US (can't find the @ and €)

And some other times everything work fine !

My "clients" pc for remote desktop are Ubuntu-Unity, with Français(variante) keyboards.

Revision history for this message
Torsten Bronger (bronger) wrote :

For the time being, does anybody have a workaround for deactivating dead keys in spite of this bug? It would be very helpful for programmers like me.

Revision history for this message
Simon Ritchie (simonritchie-uk) wrote :

This bug has suddenly become a lot more serious. It appears that it now affects machines that have applied a standard Linux software update.

I'm running Ubuntu 14.04 (the current standard). I use a UK keyboard layout. I applied an upgrade and rebooted, and the "@" key and the doublequote key were swapped. Uninstalling ibus and rebooting fixed the problem.

If I understand the issue, it affects anybody with a non-US keyboard, and different characters will be swapped depending on what keyboard layout they use.

The problem is that if the user's password contains one of the swapped characters, they will not be able to log in after upgrading and rebooting. They logged in successfully last time, so they will simply see a single box on the screen requesting their password. What they type will not be displayed, obviously. They type their password and the system will reject it. Until they know what the problem is, and which characters get swapped on their keyboard, they can't log in to fix the problem.

This could affect several million Linux users around the world and render their machines useless.

Revision history for this message
Nasser (raoufan) wrote :

Simon Ritchie you are fantastic. I love you because you prevent me to pull off my hairs. Now my kb is well working. ;-)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.