DVD-RAM bug seems to hang gvfs

Bug #601410 reported by Dan McGrath
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)

Bug Description

Binary package hint: gvfs

Hi. I am currently experiencing some problems with DVD-RAM media under
ubuntu lucid lynx, and I was wondering if you might recognize some of
the behaviour as being normal, or a bug.

What I do is insert a disk, then issue `mkudffs --media-type=dvdram
--utf8 /dev/sr0` and then `mount /media/cdrom0`. All seems to go well
and I get an entry that shows up as:

 /dev/sr0 on /media/cdrom0 type udf (rw,nosuid,nodev,utf8,user=dan)

At this point, I tried a simple copy of the linux git repository
(~850mb), but 3 hours later it is still copying. With other small test
writes, I also noticed that when I issue a umount, the command blocks
for maybe 10 seconds, then returns, yet the drive light appears to
continue to be writting for at least 5 minutes past the umount. At
that point it starts spiking a nice'd load or something, on one of the
cores of my system to 100% and stays there until I eject the disk. The
problem is that ejecting the disk seems to mess up the copy as well.
And even after I eject, the load stays at 100% on one core.

As for the drive, it is:

wodim: Overview of accessible drives (1 found) :
 0 dev='/dev/scd0' rwrw-- : 'HL-DT-ST' 'DVDRAM GH22NS50'

Current kernel: Linux wks 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11
08:03:28 UTC 2010 x86_64 GNU/Linux

It seems that even after I umount, a program called
gvfs-gdu-volume-monitor starts going nuts writting to the disc and
pegging one of the cores, followed by udevd using 100% after an
eject+reinsert. Correct me if I am wrong, but absolutely nothing
should be writting to any device after a umount, no?

Anyways, until I can track down exactly what might be interfering with
the writes, I would love to hear back on if I am just doing something
incorrectly. Any help would be appreciated. Thanks!


ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gvfs 1.6.1-0ubuntu1build1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: c3db184c2753f743b7cb62d6a698ae29
CheckboxSystem: da9af3b901b5569a389df6337f3d812f
Date: Sat Jul 3 12:13:02 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: gvfs

Revision history for this message
Dan McGrath (troubled) wrote :
Revision history for this message
Dan McGrath (troubled) wrote :

It seems that if I manually mkfs.ext2 (or whatever) the drive and mount it manually, everything is just fine.

That being said, perhaps it would be nice to have ubuntu treat DVD-RAM disks specially and prompt the user to format it with a real filesystem and mount it accordingly?

Although I am still seeing the system sync the device after umount though, still consider that to be a design flaw IMHO.

Revision history for this message
EricDHH (ericdhh) wrote :

Tryin ext2 did not work here, first i format the dvdram well with -b2048 in ext2. But when re-inserted the following comes up

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sr1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Can dvdram be completely bogus with lucid? Worked well before like many others borken things now:-/

Revision history for this message
Dan McGrath (troubled) wrote :


I guess I should have mentioned that after you mkfs.ext2, you need to manually mount it with a command like:

  mount /dev/sr1 /media/cdom

It seems that the default fstab entry is expecting iso9660 or udf instead of ext2. Otherwise, it should mount and work fine, other than the above mentioned problems with sync after umount.

Revision history for this message
Dan McGrath (troubled) wrote :

Actually, I should also mention that I crossposted this bug at:


That bug problem has a lot more information on the problem and how I deal with it than this bug report does. Hope this helps.

Revision history for this message
Dan McGrath (troubled) wrote :

I guess that this problem might be resolved as of 10.10? (see bug below)


Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gvfs (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gvfs (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.