Candidate release 1.8.8+1-2ubuntu1

Bug #773945 reported by أحمد المحمودي (Ahmed El-Mahmoudy)
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
guile-1.8 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: guile-1.8

guile-1.8 (1.8.8+1-2ubuntu1) oneiric; urgency=low

  * Merge from Debian, remaining Ubuntu changes:
    - Build with -Wno-error.
    - Build with thread support. Some guile-using programs like autogen need
      it.
    - Add debian/guile-1.8-libs.shlibs: Thread support breaks ABI, bump the
      soname.
    - Build with -O on ia64 to ftbfs.

 -- أحمد المحمودي (Ahmed El-Mahmoudy) <email address hidden> Sat, 30 Apr 2011 10:38:24 +0200

guile-1.8 (1.8.8+1-2) unstable; urgency=low

  * Don't access uninitialized memory in scm_to_sockaddr().
    Thanks to Thorsten Glaser <email address hidden> for the patch.

  * Add flex as a build dependency.
    Thanks to Thorsten Glaser <email address hidden> for the patch.

 -- Rob Browning <email address hidden> Wed, 27 Apr 2011 22:26:20 -0500

guile-1.8 (1.8.8+1-1) unstable; urgency=low

  * Incorporate upstream release 1.8.8. (closes: #616694)

  * Switch to 3.0 (quilt) source format.

  * Rewrite debian/rules to use "dh $@"; update debian/compat to 8, and
    let dh_auto* handle as much as possible.

  * Depend on libltdl-dev and libgmp-dev, not libltdl3-dev and libgmp3-dev.
    Thanks to Jordi Mallach <email address hidden> for the fix.

  * Remove *.la files from all debs (wheezy release goal).
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #621240)

  * Add guile1.4 conflict to guile-1.8 package.
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #523949)

  * Add a homepage field to the control file.
    Thanks to Jordi Mallach <email address hidden> for the suggestion.

  * Make guile-1.8 and guile-1.8-dev depend on current guile-1.8-libs version.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441241)

  * Restore guile-1.8-slib package now that Guile supports it again.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441110)

  * Update package descriptions.

  * Export fake HOME to make sure the build process doesn't touch the real one.
    Thanks to Jordi Mallach <email address hidden> for the fix.

 -- Rob Browning <email address hidden> Tue, 26 Apr 2011 20:41:29 -0500

Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package guile-1.8 - 1.8.8+1-2ubuntu1

---------------
guile-1.8 (1.8.8+1-2ubuntu1) oneiric; urgency=low

  * Merge from Debian (LP: #773945), remaining Ubuntu changes:
    - Build with -Wno-error.
    - Build with thread support. Some guile-using programs like autogen need
      it.
    - Add debian/guile-1.8-libs.shlibs: Thread support breaks ABI, bump the
      soname.
    - Build with -O on ia64 to ftbfs.

guile-1.8 (1.8.8+1-2) unstable; urgency=low

  * Don't access uninitialized memory in scm_to_sockaddr().
    Thanks to Thorsten Glaser <email address hidden> for the patch.

  * Add flex as a build dependency.
    Thanks to Thorsten Glaser <email address hidden> for the patch.

guile-1.8 (1.8.8+1-1) unstable; urgency=low

  * Incorporate upstream release 1.8.8. (closes: #616694)

  * Switch to 3.0 (quilt) source format.

  * Rewrite debian/rules to use "dh $@"; update debian/compat to 8, and
    let dh_auto* handle as much as possible.

  * Depend on libltdl-dev and libgmp-dev, not libltdl3-dev and libgmp3-dev.
    Thanks to Jordi Mallach <email address hidden> for the fix.

  * Remove *.la files from all debs (wheezy release goal).
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #621240)

  * Add guile1.4 conflict to guile-1.8 package.
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #523949)

  * Add a homepage field to the control file.
    Thanks to Jordi Mallach <email address hidden> for the suggestion.

  * Make guile-1.8 and guile-1.8-dev depend on current guile-1.8-libs version.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441241)

  * Restore guile-1.8-slib package now that Guile supports it again.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441110)

  * Update package descriptions.

  * Export fake HOME to make sure the build process doesn't touch the real one.
    Thanks to Jordi Mallach <email address hidden> for the fix.
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden> Sat, 30 Apr 2011 10:38:24 +0200

Changed in guile-1.8 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.