system monitor uses incorrect network speed (throughput) units

Bug #366235 reported by Коренберг Марк
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Low
gnome-system-monitor (Ubuntu)
Fix Released
Low
Robert Roth

Bug Description

Binary package hint: gnome-system-monitor

Network monitor uses incorrect units for showing network throughput. It uses MiB/sec, KiB/sec and so on.

http://physics.nist.gov/cuu/Units/binary.html
Examples and comparisons with SI prefixes
one kibibit 1 Kibit = 2^10 bit = 1024 bit
one kilobit 1 kbit = 10^3 bit = 1000 bit
one mebibyte 1 MiB = 2^20 B = 1 048 576 B
one megabyte 1 MB = 10^6 B = 1 000 000 B
one gibibyte 1 GiB = 2^30 B = 1 073 741 824 B
one gigabyte 1 GB = 10^9 B = 1 000 000 000 B

Specifying network throughput in some units of bytes/sec is incorrect. The network throughput should always specified in some units of bits/sec (kbits,mbits per second). The speed of downloading a file may be specified in KiB/sec. is's OK, but not for netowrk device throughput. Please fix. At least add option into preferences...

mmarkk@mmarkk-ubuntu:~$ LANG=C lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/gnome-system-monitor
Package: gnome-system-monitor 2.24.1-0ubuntu1
ProcEnviron:
 LANG=ru_RU.UTF-8
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 SHELL=/bin/bash
SourcePackage: gnome-system-monitor
Uname: Linux 2.6.27-11-generic i686

Tags: apport-bug
Revision history for this message
Коренберг Марк (socketpair) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
Revision history for this message
Коренберг Марк (socketpair) wrote :

NO! there are many bugs about units used in free space of file systems. i did not find duplicate bugs about network throughput.

Changed in gnome-system-monitor (Ubuntu):
status: Invalid → New
Revision history for this message
Коренберг Марк (socketpair) wrote : Re: [Bug 366235] Re: system monitor uses incorrect network speed units

This is not dulicate bug about 'uses unusual units to report memory
and disk sizes'

I saw already bug #80780. There is no any words about network
throughput. Only about sizes of memory and hard drives. Please remove
duplicate bug. Please don't mix them.

My bug said, that speed should be measured in units of bits per secnd,
and not in bytes/per second.
Bug #80780 said about 1000-based units and 1024-based units.

2009/4/25 Sebastien Bacher <email address hidden>:
> *** This bug is a duplicate of bug 80780 ***
>    https://bugs.launchpad.net/bugs/80780
>
> ** This bug has been marked a duplicate of bug 80780
>   uses unusual units to report memory and disk sizes
>
> --
> system monitor uses incorrect network speed units
> https://bugs.launchpad.net/bugs/366235
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-monitor” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gnome-system-monitor
>
> Network monitor uses incorrect units for showing network throughput. It uses MiB/sec, KiB/sec and so on.
>
> http://physics.nist.gov/cuu/Units/binary.html
> Examples and comparisons with SI prefixes
> one kibibit      1 Kibit = 2^10 bit = 1024 bit
> one kilobit      1 kbit = 10^3 bit = 1000 bit
> one mebibyte     1 MiB = 2^20 B = 1 048 576 B
> one megabyte     1 MB = 10^6 B = 1 000 000 B
> one gibibyte     1 GiB = 2^30 B = 1 073 741 824 B
> one gigabyte     1 GB = 10^9 B = 1 000 000 000 B
>
> Specifying network throughput in some units of bytes/sec is incorrect. The network throughput should always specified in some units of bits/sec (kbits,mbits per second). The speed of downloading a file may be specified in KiB/sec. is's OK, but not for netowrk device throughput. Please fix. At least add option into preferences...
>
> mmarkk@mmarkk-ubuntu:~$ LANG=C lsb_release -rd
> Description:    Ubuntu 8.10
> Release:        8.10
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/bin/gnome-system-monitor
> Package: gnome-system-monitor 2.24.1-0ubuntu1
> ProcEnviron:
>  LANG=ru_RU.UTF-8
>  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
>  SHELL=/bin/bash
> SourcePackage: gnome-system-monitor
> Uname: Linux 2.6.27-11-generic i686
>

--
Segmentation fault

summary: - system monitor uses incorrect network speed units
+ system monitor uses incorrect network speed (throughput) units
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug should be opened by somebody who has an opinion about that on bugzilla.gnome.org where the people writting the software will read it too

Revision history for this message
Коренберг Марк (socketpair) wrote : Re: [Bug 366235] Re: system monitor uses incorrect network speed (throughput) units

I dont' understand, what i should now do, if I want my bug fixed ?

2009/4/25 Sebastien Bacher <email address hidden>:
> the bug should be opened by somebody who has an opinion about that on
> bugzilla.gnome.org where the people writting the software will read it
> too
>
> --
> system monitor uses incorrect network speed (throughput) units
> https://bugs.launchpad.net/bugs/366235
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-monitor” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gnome-system-monitor
>
> Network monitor uses incorrect units for showing network throughput. It uses MiB/sec, KiB/sec and so on.
>
> http://physics.nist.gov/cuu/Units/binary.html
> Examples and comparisons with SI prefixes
> one kibibit      1 Kibit = 2^10 bit = 1024 bit
> one kilobit      1 kbit = 10^3 bit = 1000 bit
> one mebibyte     1 MiB = 2^20 B = 1 048 576 B
> one megabyte     1 MB = 10^6 B = 1 000 000 B
> one gibibyte     1 GiB = 2^30 B = 1 073 741 824 B
> one gigabyte     1 GB = 10^9 B = 1 000 000 000 B
>
> Specifying network throughput in some units of bytes/sec is incorrect. The network throughput should always specified in some units of bits/sec (kbits,mbits per second). The speed of downloading a file may be specified in KiB/sec. is's OK, but not for netowrk device throughput. Please fix. At least add option into preferences...
>
> mmarkk@mmarkk-ubuntu:~$ LANG=C lsb_release -rd
> Description:    Ubuntu 8.10
> Release:        8.10
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/bin/gnome-system-monitor
> Package: gnome-system-monitor 2.24.1-0ubuntu1
> ProcEnviron:
>  LANG=ru_RU.UTF-8
>  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
>  SHELL=/bin/bash
> SourcePackage: gnome-system-monitor
> Uname: Linux 2.6.27-11-generic i686
>

--
Segmentation fault

Revision history for this message
Sebastien Bacher (seb128) wrote :

ubuntu is just distributing this software, you want to argue about such change with the people writting the code and you need to open a bug on http://bugzilla.gnome.org

Revision history for this message
Endolith (endolith) wrote :

Network speed should be in 1000s of bits per second, as it is used everywhere else.

kbit/s = 1,000 bit/s
Mbit/s = 1,000,000 bit/s
...

Revision history for this message
Коренберг Марк (socketpair) wrote :

yes, I agree with you.

But if you look to graph, you will notice, that speed in some units of bytes/sec

2009/4/27 Endolith <email address hidden>:
> Network speed should be in 1000s of bits per second, as it is used
> everywhere else.
>
> kbit/s = 1,000 bit/s
> Mbit/s = 1,000,000 bit/s
> ...
>
> --
> system monitor uses incorrect network speed (throughput) units
> https://bugs.launchpad.net/bugs/366235
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-monitor” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gnome-system-monitor
>
> Network monitor uses incorrect units for showing network throughput. It uses MiB/sec, KiB/sec and so on.
>
> http://physics.nist.gov/cuu/Units/binary.html
> Examples and comparisons with SI prefixes
> one kibibit      1 Kibit = 2^10 bit = 1024 bit
> one kilobit      1 kbit = 10^3 bit = 1000 bit
> one mebibyte     1 MiB = 2^20 B = 1 048 576 B
> one megabyte     1 MB = 10^6 B = 1 000 000 B
> one gibibyte     1 GiB = 2^30 B = 1 073 741 824 B
> one gigabyte     1 GB = 10^9 B = 1 000 000 000 B
>
> Specifying network throughput in some units of bytes/sec is incorrect. The network throughput should always specified in some units of bits/sec (kbits,mbits per second). The speed of downloading a file may be specified in KiB/sec. is's OK, but not for netowrk device throughput. Please fix. At least add option into preferences...
>
> mmarkk@mmarkk-ubuntu:~$ LANG=C lsb_release -rd
> Description:    Ubuntu 8.10
> Release:        8.10
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/bin/gnome-system-monitor
> Package: gnome-system-monitor 2.24.1-0ubuntu1
> ProcEnviron:
>  LANG=ru_RU.UTF-8
>  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
>  SHELL=/bin/bash
> SourcePackage: gnome-system-monitor
> Uname: Linux 2.6.27-11-generic i686
>

--
Segmentation fault

Revision history for this message
Pedro Villavicencio (pedro) wrote :

did you opened an upstream report? may you tell us the bug number there? thanks.

Revision history for this message
Коренберг Марк (socketpair) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=580471

2009/4/27 Pedro Villavicencio <email address hidden>:
> did you opened an upstream report? may you tell us the bug number there?
> thanks.
>
> --
> system monitor uses incorrect network speed (throughput) units
> https://bugs.launchpad.net/bugs/366235
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-monitor” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gnome-system-monitor
>
> Network monitor uses incorrect units for showing network throughput. It uses MiB/sec, KiB/sec and so on.
>
> http://physics.nist.gov/cuu/Units/binary.html
> Examples and comparisons with SI prefixes
> one kibibit      1 Kibit = 2^10 bit = 1024 bit
> one kilobit      1 kbit = 10^3 bit = 1000 bit
> one mebibyte     1 MiB = 2^20 B = 1 048 576 B
> one megabyte     1 MB = 10^6 B = 1 000 000 B
> one gibibyte     1 GiB = 2^30 B = 1 073 741 824 B
> one gigabyte     1 GB = 10^9 B = 1 000 000 000 B
>
> Specifying network throughput in some units of bytes/sec is incorrect. The network throughput should always specified in some units of bits/sec (kbits,mbits per second). The speed of downloading a file may be specified in KiB/sec. is's OK, but not for netowrk device throughput. Please fix. At least add option into preferences...
>
> mmarkk@mmarkk-ubuntu:~$ LANG=C lsb_release -rd
> Description:    Ubuntu 8.10
> Release:        8.10
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/bin/gnome-system-monitor
> Package: gnome-system-monitor 2.24.1-0ubuntu1
> ProcEnviron:
>  LANG=ru_RU.UTF-8
>  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
>  SHELL=/bin/bash
> SourcePackage: gnome-system-monitor
> Uname: Linux 2.6.27-11-generic i686
>

--
Segmentation fault

Revision history for this message
Коренберг Марк (socketpair) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gnome-system-monitor (Ubuntu):
status: New → Triaged
Changed in gnome-system-monitor:
status: Unknown → New
Changed in gnome-system-monitor:
status: New → In Progress
Changed in gnome-system-monitor:
importance: Unknown → Low
status: In Progress → Confirmed
Revision history for this message
Robert Roth (evfool) wrote :

An option has been added in the preferences for users to choose between bit or byte-based network bandwidth, but the default is still the byte-based. Ubuntu should have a patch changing this default (network-in-bits from the gsettings schema should default to true) to comply with the Ubuntu units policy.

Changed in gnome-system-monitor (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Roth (evfool)
status: Triaged → In Progress
Changed in gnome-system-monitor:
status: Confirmed → Fix Released
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Jeremy Bícha (jbicha) wrote :

Personally, I prefer my network throughput to be measured with the same units as file downloads. Therefore, I don't think there's a good reason to override upstream's default of measuring in bytes instead of bits. Anyone that prefers network speed in bits can easily change that in Edit>Preferences.

Revision history for this message
Robert Roth (evfool) wrote :

@jbicha: If the file downloads are measured in *byte/s, than that should be changed to bit-based, just like this bug to be consistent. The Ubuntu units policy [1] clearly states that base-10 (kB, MB, etc.) should be used to measure network bandwidth, which seems to be the case for download speeds, upload speeds etc. So consistency should be a goal, either by using base-2 everywhere and changing the Units policy, or by fixing the apps showing download/upload to display in base-10.

[1] https://wiki.ubuntu.com/UnitsPolicy

Revision history for this message
Robert Roth (evfool) wrote :

Closing this issue, as there is a preference available to set the network speed units, so this issue has been fixed. Compliance with the Ubuntu Units Policy[1] is another issue, and should be treated separately, if required.

[1] https://wiki.ubuntu.com/UnitsPolicy

Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.