gdm displays no user at startup in Ubuntu Maverick

Bug #614810 reported by Lorenzo Zoffoli
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: gdm

gdm displays no user to choose neither an input field where write the username by hand.

Log:
Window manager warning: Failed to read saved session file /var/lib/gdm/.config/metacity/sessions/10668c589f17d3cd5128120640536450000000014300008.ms: Failed to open file '/var/lib/gdm/.config/metacity/sessions/10668c589f17d3cd5128120640536450000000014300008.ms': No such file or directory
** (process:1557): DEBUG: Greeter session pid=1557 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-qqS3cn/database

(gnome-power-manager:1556): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.25.12.is.2.25.12/gobject/gsignal.c:2275: signal `proxy-status' is invalid for instance `0x25c2570'
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
gdm-simple-greeter[1557]: Gtk-WARNING: /build/buildd/gtk+2.0-2.21.5/gtk/gtkwidget.c:5676: widget not within a GtkWindow
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1000047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1000047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:1556): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Changed in gdm (Ubuntu):
status: New → Confirmed
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This is telling:

The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.

GDM hides users without a valid shell. Could you please attach this file?

Changed in gdm (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Daniel Holbach (dholbach) wrote :

daniel@miyazaki:~$ cat /etc/shells
# /etc/shells: valid login shells
/bin/csh
/bin/sh
/usr/bin/es
/usr/bin/ksh
/bin/ksh
/usr/bin/rc
/usr/bin/tcsh
/bin/tcsh
/usr/bin/esh
/bin/dash
/bin/bash
/bin/rbash
/usr/bin/screen
daniel@miyazaki:~$ export | grep SHELL
declare -x SHELL="/bin/bash"
daniel@miyazaki:~$ ls -l /bin/bash
-rwxr-xr-x 1 root root 818232 2010-04-19 03:51 /bin/bash
daniel@miyazaki:~$

Revision history for this message
Martin Emrich (emme) wrote :

Same here (maverick i386). My shell is /bin/bash, which is listed in /etc/shells.

Changed in gdm (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Did that start in the recent update? Does it happen every time? Does it happen a start or after a logout? It could be a race, I've seen that happening on some boxes after logout

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
Daniel Holbach (dholbach) wrote :

I can not log in at all. I need to install and use xdm to log in, so logging in and out in gdm is not an option. It just started happening this weekend.

Revision history for this message
Björn Schließmann (b-schliessmann) wrote :

For me, those symptoms started with gdm 2.30.4-0ubuntu1.

I second the race condition, since the problem doesn't always appear. Sometimes after booting (minority of cases), the user list is shown normally.

P.S.: Workaround: No need to install xdm. Just log into a VT and enter "startx".

Revision history for this message
Björn Schließmann (b-schliessmann) wrote :

Addition to my previous comment, referring to #4:
- version see above
- doesn't happen everytime, but when it happens (normally directly after booting), restarting gdm (sudo restart gdm) doesn't help.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gdm (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

I found this in the logs after enabling debug messages:
gdm-simple-slave[2092]: DEBUG(+): GdmSlave: Requesting timed login details
gdm-simple-slave[2092]: DEBUG(+): GdmSlave: Got timed login details: 0 0
gdm-simple-slave[2092]: DEBUG(+): Invalid NULL username for auto/timed login

After adding the following to /etc/gdm/custom.conf it works again (don't ask me why):

[daemon]
TimedLoginEnable=false
AutomaticLoginEnable=false

[debug]
Enable=true

Changed in gdm (Ubuntu):
importance: Low → Medium
Revision history for this message
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at https://bugzilla.gnome.org/show_bug.cgi?id=626564 ; feel free to add comments and subscribe to it, thanks.

Changed in gdm (Ubuntu):
status: Confirmed → Triaged
Changed in gdm:
importance: Undecided → Unknown
status: New → Unknown
Changed in gdm:
status: Unknown → New
Revision history for this message
Daniel Holbach (dholbach) wrote :

Sorry, what I said in #9 is not true. It looks like it just worked once. :-(

Changed in gdm (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.30.5-0ubuntu1

---------------
gdm (2.30.5-0ubuntu1) maverick; urgency=low

  * New upstream version:
    - Retry getpw* calls if they return EINTR
    - #619588, don't show markup tags in UI (lp: #603097)
    - #626564, fix intermittent failure to load user list (lp: #614810)
 -- Sebastien Bacher <email address hidden> Wed, 11 Aug 2010 21:50:35 +0200

Changed in gdm (Ubuntu):
status: Fix Committed → Fix Released
Changed in gdm:
status: New → Fix Released
Changed in gdm:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.