Jaunty gdm binds to ipv6 udp only

Bug #393835 reported by Damiano
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: gdm

A fresh install of jaunty Ubuntu 9.04 results into gdm binding on ipv6 only

netstat -a shows
udp6 0 0 [::]:xdmcp [::]:*

with kernel 2.6.28-13 it is not possible to disable ipv6 easily and I need to connect to Ubuntu from a Windows machine (ipv4) using NX client for windows.

It seems to me that this is not a duplicate of bug #162678 even if the summary seems close enough.

I did try to find for a LISTEN directive for gdm, but it does not seems to be there (at least on gdm.conf manual)

I hope I am being helpful.

Tags: ipv6
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Damiano (ubuntu-engidea) wrote :

Hi Sebastian

* Is this reproducible?
As far as I know, yes, just enable remote Login

* If so, what specific steps should we take to recreate this bug?
Install a fresh Jaunty 9.04
System->Administration->Login Window
Then enable a remote login using Remote->Style "Plain with face browser"

Reboot and if you look with netstat -a you will see that xdmcp is bound to ipv6 only

Revision history for this message
Sebastien Bacher (seb128) wrote :

is there anything not working due to that?

Revision history for this message
Damiano (ubuntu-engidea) wrote :

It is not possible to connect to gdm (remote login) to an ubuntu jaunty box coming from an IPV4 machine.

I did try to use this http://en.wikipedia.org/wiki/NX_technology and I think it does not work because ugintu is bound to IPV6 only.

Revision history for this message
Sebastien Bacher (seb128) wrote :

changing to new, to look at by somebody having the issue

Changed in gdm (Ubuntu):
status: Incomplete → New
Revision history for this message
MNLipp (mnl) wrote :

I can confirm the issue. It is most annoying (I'll have to work around by using kdm).

Revision history for this message
Srdan Dukic (srdan-dukic) wrote :

Hi, I can also confirm this issue. From the look of things this bug has been around for a while.

Discussion of bug on Ubuntu Forums: http://ubuntuforums.org/showthread.php?t=1131190

FreeBSD Discussion of bug: http://fixunix.com/freebsd/296390-x11-gdm-default-ipv6-disables-ipv4-xdmcp.html

Suggested Workaround (from Dapper 6.06): http://utcc.utoronto.ca/~cks/space/blog/linux/IndirectXdmIPv6Bug

Duplicates of this bug:

https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/105938
https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/58071

How can we get this fixed? Are the upstream developers even aware of this issue? In the second duplicate listed there appears to be a workaround involving DNS, but I haven't tried it out myself.

Revision history for this message
Srdan Dukic (srdan-dukic) wrote :
Emmet Hikory (persia)
tags: added: ipv6
Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.30.4-0ubuntu1

---------------
gdm (2.30.4-0ubuntu1) maverick; urgency=low

  [ Sebastien Bacher ]
  * New upstream versions:
    - Translation fixes
    - Many performance improvements for the greeter
    - Various robustness fixes
    - Fix XDMCP
    - Fix switch user menu item detection
    - Remove obsolete restart and stop scripts
    - Fixed #618834, GdmProductSlave does not handle OpenSession
    - Fixed #342397, gdm doesn't respond to XDMCP querys if local X server fails
      to start
    - Fixed #544730, XDMCP broadcast discovery not working on BSD w/ ipv6
      enabled (lp: #393835)
    - Fixed #589536, gdm-simple-slave crashed with signal 5 in
      g_return_if_fail_warning (lp: #403441)
    - Fixed #592183, GDM entry field loses focus after dialogs are presented
    - Fixed #594857, Warning when type 'gdm --version' in terminal in new GDM
    - Fixed #599683, xdmcp Queries from Older software
    - Fixed #610179, GDM patch for accounts dialogue
    - Fixed #616722, Xdmcp linking problem
    - Fixed #616730, user-switch-applet build failure: missing -I for dbus-glib
    - Fixed #617665, Panel doesn't shrink after disabling "high contrast"
    - Fixed #619588, User's Real names should be escaped against XML markup
      (lp: #499690, #585128)
    - Fixed #620430, memory leaks in gdm
    - Fixed #620893, bottom panel is overlapping at smaller sizes
    - Fixed #620908, gdm user switch applet goes nuts while
      changing password file
    - Fixed #621045, Improve startup performance of the greeter
    - Fixed #621131, User switch applet performance issues
    - Fixed #621661, Make slaves more robust against crashes
    - Fixed #622069, greeter doesn't work when there's no local user
    - Fixed #622337, shows shutdown buttons when connecting over xdmcp
    - Fixed #622430, keyboard layout handling wonky
    - Fixed #622431, cancel button not shown during timed login
    - Fixed #601458, Add presence items to status menu and port to JS
  * Refresh distribution changes
  * debian/patches/07_correct_distribution_version.patch:
    - use upstream version
  * debian/patches/13_cache_ck_history.patch:
    - dropped since the new upstream version solves this issue differently
  * debian/patches/23_login_window_hint.patch:
    - dropped, the change is in the new version

  [ Kees Cook ]
  * debian/patches/24_system_uid.patch: - updated for upstream code changes

  [ Robert Ancell ]
  * debian/xsession.desktop:
  * debian/xterm.desktop:
    - Use clearer session names (LP: #599336)
  * debian/patches/09_gdmsetup.patch:
    - Remove session comment from combo box to make it fit better

  [ Martin Pitt ]
  * 09_gdmsetup.patch: Only show "Play Login Sound" checkbox if we have
    /usr/share/gdm/autostart/LoginWindow/libcanberra-ready-sound.desktop.
  * Add 01_upower.patch: Port to UPower.
  * debian/control: libdevkit-power-gobject-dev → libupower-glib-dev.
 -- Kees Cook <email address hidden> Fri, 06 Aug 2010 13:02:51 +0200

Changed in gdm (Ubuntu):
status: Fix Committed → Fix Released
Changed in gdm:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

Still happening on Lucid (which is LTS), with gdm version 2.30.2.is.2.30.0-0ubuntu4.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.