fglrx causes segmentation fault on boot

Bug #1267650 reported by a2r
This bug affects 8 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
Nominated for Trusty by Alberto Salvia Novella

Bug Description

With fglrx-updates installed Ubuntu 14.04 freezes while the bootscreen (shiny ubuntu logo). Can't get into TTY and have to turn the computer off with the powerbutton.

I'm on Ubuntu 14.04 freshly updated.
Graphics card is a Mobility Radeon 5650.

Revision history for this message
a2r (a2r) wrote :
a2r (a2r)
description: updated
papukaija (papukaija)
tags: added: trusty
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Revision history for this message
Lukáš Chmela (lukaschmela) wrote :

I can confirm this behavior since fglrx 12.11 if I am right. The only exception was fglrx-updates package from Ubuntu 13.04 repository which I am using now (the fglrx package from the same repository causes system freeze like all the other versions do).

Relevant (unsolved) threads are probably:

I have Acer Aspire 8943G notebook with AMD Mobility Radeon HD 5850 (Intel IGPU disabled in BIOS).

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

It renders the system temporarily or permanently unusable.

Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Ge-org Brohammer (george97477) wrote :

Still causing my system to freeze at boot if I install this package.

Revision history for this message
Lukáš Chmela (lukaschmela) wrote :

Ge-org Brohammer have you also tried the new AMD Catalyst 14.6 beta from official AMD's webpage?

Revision history for this message
Ge-org Brohammer (george97477) wrote :

No, do I require any special installation instructions?

Revision history for this message
Lukáš Chmela (lukaschmela) wrote :

The installation is just about running:
chmod +x amd*
./amd* --buildpkg Ubuntu/trusty
sudo dpkg -i *.deb

But you would need to install some build dependencies (exact steps should be here: http://wiki.cchtml.com/index.php/Ubuntu_Trusty_Installation_Guide#Before_you_start). Anyway, I tested all the official AMD versions except the recently released 14.6 beta. None of them fixed the problem so I highly doubt this one will make any difference.

Revision history for this message
G (smiler2505) wrote :

Can confirm bug still exists in 14.6 on Ubuntu Trusty (clean install).

I've monitored this for a while and tried to find solutions but there is nothing I can find to help resolve it. Personally I have an Acer 8943G with HD 5850 gfx. From what I have seen/people posted, what is common to the bug is this (please post if you don't have this setup!):

Acer laptop
AMD Mobility HD 5*** chip

Acer do something 'special' with the graphics chips on their laptops, it was a pain setting up video on a hackintosh on my last two, and I think this is related to the issue we have, which requires AMD to come up with some workaround unfortunately. Posting my xorg.log too to confirm it is this problem with 'failed to open a CMMQS connection'.

Revision history for this message
G (smiler2505) wrote :

Would encourage people to fill out the response here to make AMD aware of the issue: http://www.amdsurveys.com/se.ashx?s=5A1E27D23CFE9B36

This is the thread on the unofficial bug reporting forum which AMD supposedly monitor, but the bug is still outstanding 1 year on, and I am keen to help resolve it, although it may require a couple of Acer systems to view and compare the issues.

Revision history for this message
Maciej (tofiszczak) wrote :

I have exacly the same problem... Freeze on Ubuntu logo after installing and reboot.
Installation with files from AMD website.

Asrock AM1H-ITX
Kabini Athlon 5350 with Radeon R3/HD 8400

Ubuntu 14.04 all updated
Catalyst 14.12 Omega (1 version earlier was affected too)

It is a nightmare...
Don't know what to do. This problem stops me from all the fun with 'non-server' part of my rig.

Revision history for this message
Richard Lam (dick-lam-1) wrote :

Hello everyone.

I have the exact same error too on my Acer 8950G with an AMD Radeon HD 6850M. Everything installs without any errors and when I reboot, Ubuntu logs a segmentation fault. I'm willing to help resolve this if possible too, since my laptop has two hard drives.

Revision history for this message
mb74 (mrb74) wrote :

I've exactly the same problem. Ubuntu 14.04 all updated. Tried fglrx, fglrx-updates an Catalyst 14.12 Omega from AMD homepage. All versions segfault on boot. Only the open source driver runs fine out of the box. But playing highend games with the open source driver is not possible. Performance too low :-(

My hardware: Lenovo G500 Core i5 and Radeon HD 8670A/8670M/8750M.
Please help!

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
boussad (picks) wrote :

This are the release notes of 13.12 and if you scroll down it says "ATI Mobility Radeon™ HD 5000 Series" in "AMD Mobility Product Family Compatibility".

So the release notes say the card IS supported.

Also, there is no downloadable file on the site your link refers to.

https://tutuapp.uno/ , https://9apps.ooo/ , https://showbox.kim/

Revision history for this message
mobjan (mobjan2) wrote :

I have the same error,Freeze on Ubuntu logo after installing and reboot. I have AMD Radeon 650M and Acer 8950G Laptop, I install Ubuntu without any issues however it started some error after installation i try to find some solution from the internet with error codes.

My AMD card is support with Upadte it show there,

but i don't know about processer compatibility.

https://tutuapp-download.com/ https://tutuappvip.info/ https://appvalley.mobi/

Revision history for this message
paull (paulljd) wrote :

Thanks, Alberto Salvia Novella (es20490446e) now my update is working. however, my VGA has some issue, sometimes it could be software compatibility. https://mediabox.buzz/ https://zinitevi.info/ https://123-movies.blog/

Revision history for this message
fas asdf (asdfs333) wrote :

I can affirm this conduct seeing that fglrx 12.11 if I am right. The handiest exception changed into fglrx-updates bundle from Ubuntu 13.04 repository https://thehomebeasts.com/ which I am using now (the fglrx bundle from the equal repository reasons system freeze like all of the other versions do) https://bugs.launchpad.net/ubuntu/+source/lxdm/+bug/1240336

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.