Eclipse will not start (Edgy)

Bug #68053 reported by T. Koehler
150
This bug affects 1 person
Affects Status Importance Assigned to Milestone
azureus (Ubuntu)
Fix Released
Undecided
Matthias Klose
Nominated for Edgy by Tobias
Nominated for Feisty by Tobias
eclipse (Ubuntu)
Fix Released
High
Matthias Klose
Nominated for Edgy by Tobias
Nominated for Feisty by Tobias

Bug Description

Eclipse will not start up in Edgy, neither with the sun-vm nor with gcj.

This is ~/workspace/.metadata/.log if started with gcj:
!SESSION 2006-10-24 20:30:40.385 -----------------------------------------------
eclipse.buildId=M20060921-0945
java.fullversion=GNU libgcj 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-14ubuntu7)
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 2 1 2006-10-24 20:30:45.675
!MESSAGE NLS missing message: initializer_error in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2006-10-24 20:30:45.675
!MESSAGE NLS missing message: fileInitializer_fileNotFound in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2006-10-24 20:30:45.675
!MESSAGE NLS missing message: fileInitializer_IOError in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2006-10-24 20:30:45.675
!MESSAGE NLS missing message: fileInitializer_missingFileName in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 4 0 2006-10-24 20:30:46.186
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: memmove
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:67)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
   at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433)
   at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
   at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:122)
   at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:75)
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
   at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
   at org.eclipse.core.launcher.Main.run(Main.java:977)
   at org.eclipse.core.launcher.Main.main(Main.java:952)

The same output is produced by both vms. I am using these eclipse packages (<keine> means <none>):
# aptitude -F"%p %V %v" search eclipse
eclipse 3.2.1-0ubu 3.2.1-0ubu
eclipse-cdt 3.0.1-3 <keine>
eclipse-common-nls 3.1.1a-16 <keine>
eclipse-ecj 3.1.2-3ubu <keine>
eclipse-ecj-gcj 3.1.2-3ubu <keine>
eclipse-efj 3.2.1-0ubu <keine>
eclipse-gcj 3.2.1-0ubu 3.2.1-0ubu
eclipse-jdt 3.2.1-0ubu 3.2.1-0ubu
eclipse-jdt-common 3.1.2-3ubu <keine>
eclipse-jdt-gcj 3.2.1-0ubu 3.2.1-0ubu
eclipse-jdt-nls 3.1.1a-16 <keine>
eclipse-nls 3.1.1a-16 <keine>
eclipse-pde 3.2.1-0ubu 3.2.1-0ubu
eclipse-pde-common 3.1.2-3ubu <keine>
eclipse-pde-gcj 3.2.1-0ubu 3.2.1-0ubu
eclipse-pde-nls 3.1.1a-16 <keine>
eclipse-platform 3.2.1-0ubu 3.2.1-0ubu
eclipse-platform-common 3.1.2-3ubu <keine>
eclipse-platform-gcj 3.2.1-0ubu 3.2.1-0ubu
eclipse-platform-nls 3.1.1a-16 <keine>
eclipse-pydev 1.2.0-1ubu <keine>
eclipse-pydev-gcj 1.2.0-1ubu <keine>
eclipse-rcp 3.2.1-0ubu 3.2.1-0ubu
eclipse-rcp-common 3.1.2-3ubu <keine>
eclipse-rcp-gcj 3.2.1-0ubu 3.2.1-0ubu
eclipse-rcp-nls 3.1.1a-16 <keine>
eclipse-sdk 3.2.1-0ubu <keine>
eclipse-sdk-nls 3.1.1a-16 <keine>
eclipse-source 3.2.1-0ubu 3.2.1-0ubu

Revision history for this message
Herbert Straub (herbert) wrote :

I got the same error after a fresh installation of ubuntu-6.10-rc-desktop-amd64.iso (without apt-get update and dist-upgrade). Eclipse doesn't start. I attached my workspace/.metadate/.log file.

Revision history for this message
Fredrik Vraalsen (fredrik-vraalsen) wrote :

I also got this problem after doing a (distribution) software update yesterday which installed eclipse 3.2.1. Attaching my .log file from trying to run with Sun jdk 1.5.0_08 amd64.

Running eclipse 3.2.1 amd64 downloaded from eclipse.org works fine however.

Revision history for this message
Matthias Klose (doko) wrote :

updating for edgy-proposed

Changed in eclipse:
assignee: nobody → doko
status: Unconfirmed → In Progress
Matthias Klose (doko)
Changed in eclipse:
importance: Undecided → High
Revision history for this message
Erick Moreno (erickmoreno) wrote :

The same with me.

Fresh installation of ubuntu-6.10-rc-desktop-amd64.iso(actually updated), eclipse 3.2.1 amd64, java version "1.5.0_09" and Eclipse not start.

Revision history for this message
claudio@ubuntu (claudio.ubuntu) wrote :

I had the same problem. I can now start eclipse by doing this:

apt-get remove --purge `dpkg -l |grep eclipse|awk '{print $2}'` `dpkg -l |grep libswt|awk '{print $2}'`

rm -rf /usr/share/eclise /usr/lib/eclipse

apt-get install eclipse

Eclipse now runs. The only problem is that it does not close when closing the application (File-Exit):

25524 pts/3 S+ 0:00 /usr/lib/eclipse/eclipse -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -install /usr/lib/eclipse -startup /usr

I will open an other bug report for this problem.

Revision history for this message
Gabriel de Perthuis (g2p) wrote :

Is it related to this?
http://dev.eclipse.org/mhonarc/lists/platform-swt-dev/msg03850.html

claudio: I think you're avoiding the bug by making the eclipse startup fall back on sun's JVM. The bug is with GCJ eclipse. Or you can verify by installing: eclipse-gcj java-gcj-compat , which is likely to make startup fail again.

Revision history for this message
T. Koehler (leavenworth) wrote :

claudio: This will not work for me. The installation pulls in the eclipse-gcj packages, and even if I manually force it to use the sun-jvm, startup will fail with the same error.

Revision history for this message
BanjoPaterson (stuart-centuryprime) wrote : Re: [Bug 68053] Re: Eclipse will not start (Edgy)

I can start Eclipse when I download it and run it from my /home directory...

I will try this tomorrow and see if it works

Regards

Stuart

claudio@ubuntu wrote:

>I had the same problem. I can now start eclipse by doing this:
>
>apt-get remove --purge `dpkg -l |grep eclipse|awk '{print $2}'` `dpkg -l
>|grep libswt|awk '{print $2}'`
>
>rm -rf /usr/share/eclise /usr/lib/eclipse
>
>apt-get install eclipse
>
>Eclipse now runs. The only problem is that it does not close when
>closing the application (File-Exit):
>
>
>25524 pts/3 S+ 0:00 /usr/lib/eclipse/eclipse -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -install /usr/lib/eclipse -startup /usr
>
>I will open an other bug report for this problem.
>
>
>

Revision history for this message
claudio@ubuntu (claudio.ubuntu) wrote :

@Gabriel de Perthuis:
Yes, I use java from SUN setting the JAVA_HOME environment variable.

However, after installing the packages you proposed:
claudio@sydney:~$ eclipse -vm /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/bin/java

eclipse runs fine and mysteriously eclipse exists fine now (see bug https://launchpad.net/distros/ubuntu/+source/eclipse/+bug/68714 )

Claudio

Revision history for this message
ApolloX (selikoff) wrote :

This is a pretty serious problem for me. I was able to run Eclipse if I downloaded it manually and ran it from my home directory (all other methods crashed on startup), but it shuts down after about 20 seconds regardless of which JVM I use.

Revision history for this message
MrEricSir (mrericsir) wrote :

When I launch Eclipse, the logo appears and the progress bar gets about halfway through. Then an "Error notifying a preference change listener" dialog appears.

Clicking Okay makes the dialog box immediately re-appear. The cycle continues until I do a "killalll java".

I'm not sure if this is the same bug everyone else is having. I've tried deleing my .eclipse folder and installing a different combination of Eclipse packages, but no go.

The temporary solution is to remove the ~/workspace/.metadata folder. As long as this folder is missing, Eclipse will launch. Unfortunately this means re-creating the entire workspace from scratch every single time.

Revision history for this message
MrEricSir (mrericsir) wrote :

I'd also like to note that I've tried the default JVM as well as Sun's JVM, following the directions on the Ubuntu Wiki. Doesn't make a difference in terms of the program starting, so I'm inclined to believe the problem is in the Eclipse package and not with the JVM.

Revision history for this message
bboe (bboe) wrote :

I'd like to add that I get the same error with a downloaded version when I chown -R root:root on the eclipse folder.

I thought that maybe if I chown the packaged install to my user it would fix the problem, however it did not.

Revision history for this message
BanjoPaterson (stuart-centuryprime) wrote :

bbzbryce wrote:

>I'd like to add that I get the same error with a downloaded version when
>I chown -R root:root on the eclipse folder.
>
>I thought that maybe if I chown the packaged install to my user it would
>fix the problem, however it did not.
>
>
>
Strange, because I downloaded the 3.2.1 gz file from Eclipse, unzipped
it to my desktop (not root), opened Eclipse and it ran fine. I wonder
if it is permissioning problems?

Regards

Stuart

Revision history for this message
Craig Keogh (cskeogh) wrote :

> I'd like to add that I get the same error with a downloaded
> version when I chown -R root:root on the eclipse folder.
> I thought that maybe if I chown the packaged install to my
> user it would fix the problem, however it did not

Same here. I downloaded eclipse 3.2.1 for AMD64, unzipped, and it crashed with the same error.

I downloaded 3.3M2 (development version) and that worked ok.

Revision history for this message
furlan (xtreme3xxx) wrote :

I have the same problem. And if i try "eclipse -vm /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/bin/java" the problem rest.

Thanks

Revision history for this message
Pander (pander) wrote :

Fix posted by claudio@ubuntu at 2006-10-27 20:45:38 UTC does not work for eclipse* (3.2.1-0ubuntu1) sun-java5-* (1.5.0-08-0ubuntu1) on AMD 64. Also not after setting /etc/eclipse/java_home and running update-java-alternatives.

Hope a fix will be available soon.

Revision history for this message
AndyTriggs (andy-triggs) wrote :

I am also experiencing this problem, with both Sun and GCJ VM's.

I've tried running RadRails 0.71 too, but with similar SWT issues, albeit more info in the trace.

Revision history for this message
Tom (jherek+ubuntu-bugs) wrote : same thing here

I have attached a traceback. Doesn't matter whether I use gcj or Sun Java5.

(I find it surprising that this made it through quality control; eclipse seems like a pretty big deal.)

Revision history for this message
Bill Cosby (splinta) wrote :

This must be a problem with the SWT 3.2 package.

The same "memmove" problem occurs with Azureus 2.5

Bill Cosby (splinta)
Changed in azureus:
status: Unconfirmed → Confirmed
Revision history for this message
Monzta (dasmonzta) wrote :

Nearly the same problem here. I will try the eclipse 3.3M3.

Revision history for this message
Philip Belemezov (phible) wrote :

Same problem (memmove) here, Edgy Eft (final, fresh install), amd64.

Revision history for this message
Bill Cosby (splinta) wrote :

So, is this already the solution to the problem?
https://launchpad.net/distros/ubuntu/+source/eclipse/+bug/68380

Revision history for this message
Scott G. Miller (sgmiller) wrote :

That solved the problem for me. Did apt-get source eclipse, applied the patch and built, then installed libswt3.2-gtk-jni, and all was well. Can we get this into the official package soon? This is affecting lots of developers around here.

Revision history for this message
Hans Duedal (hans-duedal) wrote :

Same thing here, downloading a version from eclipses sites and running seemed to work somewhat. I would really prefer to get one via apt-get, and I would prefer not to build it myself.

Edgy Eft, also final, amd64

Revision history for this message
Sebastian Kaps (spambucket) wrote :

This didn't work for me.
I got the source, applied the debdiff and built the whole thing.
After installing either all the resulting deb-packets or only the libswt3.2-gtk-jni packet I still get the same error.

Any suggestions?

Revision history for this message
Hans Duedal (hans-duedal) wrote :

I finally got stable Eclipse running... Had to
 1. Download Eclipse from their website (http://www.eclipse.org/downloads/)
 2. Download and install Sun Java 64 bit
 3. Point Eclipse to that JVM

Use this guide as reference:
http://www.ubuntuforums.org/showthread.php?t=201378&highlight=eclipse

That is the only way i got a *stable* eclipse running on x86_64.

Anyway its stable as long as I don't push "Web browser" then it will fail with a GWT error.

Please devs, fix this bug :)

Revision history for this message
Sebastian Kaps (spambucket) wrote :

This also does not work for me.
Still the same error.

Revision history for this message
dun (dun) wrote :

Wow. You'd think a bug of this magnitude would be fixed in a few days. Guess Edgy isn't so stable after all.

Revision history for this message
Johan Christiansen (johandc) wrote :

Same problem here, Feisty on AMD64.

Could you write a guide how to apply the proposed patch, or perhaps rebuild the packages in the repos? Eclipse is very important to me.

Revision history for this message
Johan Christiansen (johandc) wrote :

Ahem, are there any progress on this? A solution has been posted, Matthias Klose is assigned and the status has been "in progress" for over three days now... I really hope something will happen soon. I miss both eclipse and azureus. Thank you :-)

Revision history for this message
Zingo Andersen (zingo) wrote :

Could at least the old version be readded until this is fixed so that version out there atleast works?

Revision history for this message
Shug (shug-boabby) wrote :

Experiencing the same thing... noticed there is a fix for this (https://launchpad.net/bugs/68380) but hasn't been committed yet. Anyone here know how I could make use of that fix in while I await for the powers-that-be to add it?

Meanwhile, I'm going to "vote" for that fix...

Revision history for this message
kassx (cosine7) (oliver-higgins) wrote :

sudo /usr/lib/eclipse/eclipse

Will get eclipse running, but it will try and load the root workspace, you have to goto /home/username/workspace it will load

Revision history for this message
ibob63 (james-tuthill) wrote :

Just tried. sudo /usr/lib/eclipse/eclipse

Got the same error message but in the root workspace.

Revision history for this message
Johan Christiansen (johandc) wrote :

Tries as root user, still same error here. It's very frustrating. Could we at least roll back the repos to the last working state?

Revision history for this message
Heikki Aitakangas (ornedan) wrote :

Running as root also fails here (x64 w/ Sun Java 1.5)

N:th the request for rollback or fixed packages

Revision history for this message
Johan Christiansen (johandc) wrote :

I just heard on #ubuntu-motu that something that looks like a fix has been released to edgy-proposed (which is a repo that you have to add manually (either using synaptic or using commandline))

I'm currently running Feisty so i cant tell you if it's true that this fixes the problem for edgy. So could somebody try to enable edgy-proposed and check?

The line in /etc/apt/sources.list would look like this:
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed restricted main multiverse universe

I hope that this may be the solution for edgy, and that it would be merged to feisty soon :)

Revision history for this message
TomCalloway (tomdeme) wrote :

Here's a fairly complete procedure that will help a relative newbie fix this problem, using the uncommitted patch provided under bug #68380.

I'm new to Linux, so forgive the excessive detail--though others may be grateful for it. It was hard won.

Revision history for this message
TomCalloway (tomdeme) wrote :

oops. here's the attachment

Revision history for this message
Sebastian Kaps (spambucket) wrote :

I've tried this a second time.
This solution does not work for me. I'm still getting the same error.

Also, there's no updated packet in edgy-proposed-updates.

I'm seriously thinking about dropping Ubuntu for something that works... :-(

Revision history for this message
TomCalloway (tomdeme) wrote :

If I can attach this 140kb file successfully, this will provide a means for everyone to check whether my i386 solution works for similar systems without having to do the long compile step.

Revision history for this message
dun (dun) wrote :

^^ Does not work for me, neither does the edgy-proposed packages. *Sigh*

Revision history for this message
dun (dun) wrote :

For those who really need Eclipse, put debian's unstable branch to sources.list and install Eclipse from there. It's version 3.1.2 if I recall correctly but at least it works.

Revision history for this message
Luke Maurer (luke-maurer) wrote :

Tom's instructions worked for me.

BTW, in bug #68380 it's suggested that this fix be "run by the release team" to "get it into edgy-proposed" - anyone know how to get that particular ball rolling?

Revision history for this message
Jan Pfeifer (pfjan) wrote :

I had the same problem, in a amd64 edgy system.

So, for the other illiterate on dpkg-buildpakcage processes like me, I did the following, and it seems to have worked:

1) go to a temporary source directory

# cd ~/src

2) get the source

# apt-get source eclipse

3) apply the patch, see bug #68380, the first thing there is the pointer to this patch (eclipse.debdiff), just download it

# patch -p0 < eclipse.debdiff

4) move into the eclipse directory

# cd eclipse-3.2.1/

5) compile the whole thing, took hours on a dual core 2.167 system, and there was lots of warning/error messages, but it seems to have worked well enough

# dpkg-buildpackage -D -nc -b

6) back to the top directory

# cd ..

7) install the newly generated .deb (all of them had the version "_3.2.1-0ubuntu2_amd64.deb"). I'm not sure if all of them are necessary or not ... but I installed all of them over:

# dpkg --install libswt3.2-*.deb eclipse-*.deb

8) go back to your normal user, and, very important, remove previous configuration/setup -- that's the way I got things working, maybe not all of it is necessary. Actually I had previously moved my projects out of the way first, and the workspace/ was always some default created by eclipse:

$ rm -rf workspace/ .eclipse/

9) run eclipse, I'm using sun's java here:

$ eclipse -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -ws gtk

hope this helps someone else :)

Revision history for this message
Sebastian Kaps (spambucket) wrote :

I did exactly this before.
I don't understand why this works for some people and not for others.

Revision history for this message
Heikki Aitakangas (ornedan) wrote :

>I did exactly this before.
>I don't understand why this works for some people and not for others.

Several bugs at work, probably. I've noticed that some reports describe different symptoms than others.

Also... Some official word on whether this is going to ever be fixed, please? I'd like to know whether I should just go ahead and use the original Eclipse releases instead of Ubuntu packages. I'd prefer not to spend a day or so configuring it properly just to find out that a working Ubuntu release has finally been made.

Revision history for this message
Robin Sheat (eythian) wrote :

Just a note, I just saw this happen in an SWT app that I wrote. I pinned down the error to be using a 64-bit JVM with 64-bit SWT libraries, _but a swt.jar file build for 32-bit_. I don't know if it's useful, but it might help someone fix it.

Revision history for this message
Johan Christiansen (johandc) wrote :

The error is still here on Feisty amd64.

Revision history for this message
Ernst Sjöstrand (ernstp) wrote :

With the latest update it works fine for me!

Revision history for this message
Ulf Karlsson (ohmega) wrote :

Confirmed. Works fine using feisty on amd64 today.

Revision history for this message
mibes (mibes) wrote :

When using the AMD64 version of Eclipse, please make sure that you are also using the AMD64 version of the JDK. You can get it from the SUN website: http://java.sun.com/javase/downloads/index.jsp

Install this version to e.g. /usr/jdk1.5.0_10 and run Eclipse with the following command:

eclipse -vm /usr/jdk1.5.0_10/bin/java

Hope this works for you!

Revision history for this message
dun (dun) wrote :

my java -version says:

dun@mars:~$ java -version
java version "1.5.0_08"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_08-b03, mixed mode)

Eclipse still does not start with this java vm.

Revision history for this message
Chad Johnson (chad-d-johnson) wrote :

Hi everyone!

I had the same problem with Eclipse 3.2.1 under a clean install (upgrade) of Ubuntu Edgy AMD64 (but not under Edgy i386). I got it working, however, by removing the files in /usr/lib/eclipse (I did not delete /usr/lib/eclipse/links/ though) and then copying the files in eclipse-SDK-3.2.1-linux-gtk-x86_64.tar.gz which I got from the eclipse download site to that directory. I then removed my ~/workspace directory entirely, and then running eclipse with the -clean parameter.

I was even able to copy my a backed up workspace directory from a previous installation to my home directory and use that (after doing a rm -rf ~/workspace first).

I made no changes to my java vm inbetween any of those steps nor to anything in /etc/alternatives. I have JDK/JRE 1.5 installed.

I still get the message "Unable to create view: memmove" in the welcome pane when eclipse starts, but everything other than that seems to work fine, including plugins.

Hope this helps someone.

Revision history for this message
Uwe L. Korn (uwelk) wrote :

I've had the problem too, build using the last maintence (unstable) build from the Eclipse-Downloadpage, it worked.
--> Problem should is solved in the coming Eclipse Release

Revision history for this message
abece (abece) wrote :

After selecting a different workspace in eclipse I could launch it again

Revision history for this message
Tobias (tobias-frech) wrote :

Hi!
I finally got it working on my AMD64. Here is my configuration:

tobi@hbd:~$ uname -a
Linux hbd 2.6.17-10-generic #2 SMP Tue Dec 5 21:16:35 UTC 2006 x86_64 GNU/Linux

tobi@hbd:~$ java -version
java version "1.5.0_08"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_08-b03, mixed mode)

tobi@hbd:~$ grep proposed /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed universe main multiverse restricted

tobi@hbd:~$ dpkg -l |grep eclipse|awk '{print $2 $3}'
eclipse3.2.1-0ubuntu2
eclipse-jdt3.2.1-0ubuntu2
eclipse-pde3.2.1-0ubuntu2
eclipse-platform3.2.1-0ubuntu2
eclipse-rcp3.2.1-0ubuntu2
eclipse-source3.2.1-0ubuntu2
tobi@hbd:~$ dpkg -l |grep eclipse|awk '{print $2,$3}'
eclipse 3.2.1-0ubuntu2
eclipse-jdt 3.2.1-0ubuntu2
eclipse-pde 3.2.1-0ubuntu2
eclipse-platform 3.2.1-0ubuntu2
eclipse-rcp 3.2.1-0ubuntu2
eclipse-source 3.2.1-0ubuntu2
tobi@hbd:~$ dpkg -l |grep swt|awk '{print $2,$3}'
libswt3.2-gtk-java 3.2.1-0ubuntu2
libswt3.2-gtk-jni 3.2.1-0ubuntu2
tobi@hbd:~$ dpkg -l |grep jdk|awk '{print $2,$3}'
sun-java5-jdk 1.5.0-08-0ubuntu1

Important: When I tried to start eclipse, I still got the same error. So I deleted the workspace, still the same error. Finally I deleted the workspace and started eclipse with "eclipse -clean" and then it worked!

While starting I get this message:
using specified vm: /usr/lib/jvm/java-1.5.0-sun

HTH!

Revision history for this message
Andrew Ross (nospam-rossfamily) wrote :

Yes, the solution proposed by Tobias works. Would be good to figure out how to update the package so that it fixes for everyone else. I suspect deleting the workspace is not needed, as long as eclipse is run with -clean first time round.

Revision history for this message
carlos (carlos-onewaylife) wrote :

The solution from Tobias also works for me, though I'm using java-gcj, not the sun jvm. I guess promoting the ubuntu2 version from proposed would fix for all?

Revision history for this message
xenesis (wagner-sim88) wrote :

The package form edgy-proposed did work for me.
I just had to use once "eclipse -clean" after the install of the package.
Afterwards it worked
I'm using sun's java VM

Revision history for this message
Graham King (graham-darkcoding) wrote :

Tobias' solution above also works for me. Except after adding:

deb http://archive.ubuntu.com/ubuntu/ edgy-proposed universe main multiverse restricted

to

/etc/apt/sources.list

dpkg still reported eclipse3.2.1-0ubuntu1, but 'apt-get install' selected the right one. Possibly my 'sudo apt-get check' or 'sudo apt-get update' helped.
Eclipse now works fine. Thanks.

The edgy-proposed Azureus package also works (same SWT problem).

Revision history for this message
Peter Baumgartner (sgt-hulka) wrote :

Tobias' solution worked here as well.

Revision history for this message
Tudor Holton (tudor) wrote :

I had a similar problem, however it was not with Eclipse directly. I simply had a java app that was compiling with gcj against the org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so file.

I followed a similar line of thinking to the above but I downloaded these packages instead:
pool/universe/e/eclipse/libswt3.2-gtk-gcj_3.2.1-0ubuntu2_amd64.deb
pool/universe/e/eclipse/libswt3.2-gtk-java_3.2.1-0ubuntu2_amd64.deb
pool/universe/e/eclipse/libswt3.2-gtk-jni_3.2.1-0ubuntu2_amd64.deb

These files can be found on your nearest mirror. :-)

You can install the packages just by clicking on them, but at some time you're going to have to do a 'sudo apt-get install -f' on a command line to remove the old ones.

This approach protects you from other issues that can happen if you add edgy-proposed to your feed.

I hope this helps someone!

Cheers,
Tudor.

Revision history for this message
Matthias Klose (doko) wrote :

fixed in eclipse_3.2.1-0ubuntu3 in edgy-updates

Changed in azureus:
assignee: nobody → doko
status: Confirmed → Fix Released
Changed in eclipse:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.