Change default handler of XML files to gedit from Firefox

Bug #1693316 reported by Will Cooke
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

By default plain XML files are opened with Firefox. More often than not this results in a error in Firefox about the XML file being invalid. It would be more useful to open these files in gedit so that you can view the content.

Only text/xml file types are affected by the proposed change.

Will Cooke (willcooke)
description: updated
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in desktop-file-utils (Ubuntu):
status: New → Confirmed
Changed in desktop-file-utils (Ubuntu):
importance: Undecided → Low
Changed in desktop-file-utils (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu3

---------------
desktop-file-utils (0.23-1ubuntu3) artful; urgency=medium

  [ Will Cooke ]
  * debian/defaults.list: Updated defaults for text/xml to use gedit
    instead of Firefox. Fixes LP: #1693316

 -- Sebastien Bacher <email address hidden> Thu, 01 Jun 2017 23:03:10 +0200

Changed in desktop-file-utils (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.