not finding cd drivers throws fatal error even though using USB

Bug #552022 reported by Maletor
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Ubuntu Installer Team

Bug Description

Binary package hint: debian-installer

When I boot from a USB the 10.04 beta1 amd64 alternate install. It tries to find CD drivers. I say no, don't do that. Then it tries something else related to finding CD Drivers. I say, hey, stop that. The installer then throws a red background up and says, well fine, if you want to try to install from USB, we are going to make that impossible. Thank you for your time. You may reboot now.

This is unacceptable. Alternate CDs, even though they are called CDs, need to be able to not only boot from USB, but Install.

Maletor (eberner)
Changed in debian-installer (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
status: New → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote : Re: [Bug 552022] [NEW] not finding cd drivers throws fatal error even though using USB

Could you please supply the exact text of the messages you see? It's a
lot easier to debug problems based on that than based on rephrasings.

Revision history for this message
AmenophisIII (amenophisiii) wrote :

im trying to install lucid beta2 from the alternate install iso too.
i used unetbootin to create a bootable usb stick from the ubuntu-10.04-beta2-alternate-amd64.iso (20100406) (and i tried to use pxe+nfs too, but since network is not available before detecting the "cdrom", there is no (easy?) way to get it working without a stick)

the first problem, as the op described, the alternate cd has no way to _not_ use a cdrom as source and bails out if it can't find one.
this can be circumvented by loop-mounting the .iso manually after the installer tells you that the "detect and mount CD-ROM" "installation step failed" ("main-menu .... ls: /lib/modules/*/*kernel/drivers/cdrom/: no such file or directory" in the syslog)

after mounting manually with "mount -tiso9660 -oloop ....iso /cdrom" in a console, selecting "load debconf preconfiguration file" continues the installation normally.

after partitioning "install the base system" fails with "debootstrap error - failed to determine the codename for the release" (syslog: "base-installer: error: exiting on error base-installer/no_codename").
according to debian bug 509775: "This typically happens because users get "creative" with combining
different installation methods or because they manually mount/unmount
things, not because of any real issue in the installer."

Revision history for this message
AmenophisIII (amenophisiii) wrote :

but according to "4.3. Preparing Files for USB Memory Stick Booting" of the ubuntu install guide this is not the correct way to install it anyway.

(although that did not work for me either.

imho the usb install is way too complicated. im used to netinstalls (since debian 3.0) and those always worked perfectly, but i spend several hours now just to get the usb install running.)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.