Compiz doesn't work on ati IGP340M card with open source driver, known to work

Bug #146188 reported by Sergio Zanchetta
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)

Bug Description

Binary package hint: compiz

Gutsy Beta Live CD.

compiz doesn't work with ATI IGP 340M

"lspci -nvv" about my card:

01:05.0 0300: 1002:4337 (prog-if 00 [VGA])
        Subsystem: 103c:002a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B+
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 66 (2000ns min), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 9000 [size=256]
        Region 2: Memory at d0300000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at d0320000 [disabled] [size=128K]
        Capabilities: <access denied>

I checked in /usr/bin/compiz but 1002:4337 is not blacklisted.

I tried:
SKIP_CHECKS=yes compiz
in terminal
and this is the output:

Checking for Xgl: not present.
Detected PCI ID for VGA: 01:05.0 0300: 1002:4337 (prog-if 00 [VGA])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1400x1050) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

All worked with Feisty and Open Source driver.

My xorg.conf

Section "Files"

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "it"

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizScrollDelta" "0"

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "Device"
 Identifier "ATI Technologies Inc Radeon IGP 330M/340M/350M"
 Driver "ati"
 BusID "PCI:1:5:0"

Section "Monitor"
 Identifier "Monitor Generico"
 Option "DPMS"

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies Inc Radeon IGP 330M/340M/350M"
 Monitor "Monitor Generico"
 DefaultDepth 24
 SubSection "Display"
  Modes "1400x1050"

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
 InputDevice "Synaptics Touchpad"

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Sorry, duplicate of Bug #144077

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.