Severe memory leak: 13 GB RAM in 3-4 hours

Bug #1751137 reported by Till Kamppeter
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Fix Released

Bug Description

I am on Bionic with a new Lenovo X1 Yoga (2nd gen., current model) with 16 GB RAM.

For some weeks now chromium-browser has a severe memory leak. It fills up 13 GB of the 16 GB RAM in 3-4 hours, independent how frequently I use the browser in this time.

I use many tabs (~20-30) and as add-ons I use Adblock Plus, Ulmon CityMaps2Go, and Google Dictionary. Next time Chromium blows up I will remove one of them to find out if an add-on is the culprit.

When Chromium fills up the memory sometimes the computer gets simply slow, sometimes the rendering engine goes away (all tabs are simply solid grey instead of shown their web page), and/or there are pop-up windows about add-ons having crashed.

To get rid of the blown-up Chromium I run "top" in a terminal window, sort by memory occupation (Shift + M) and kill the process making the first place in the list (K, then 2 times Enter). This blown-up process is always the master process of Chromium, not one of the tabs, as killing this process pulls down Chromium completely (and frees the RAM).

"About Chromium" shows:

Version 64.0.3282.167 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)

till@till-x1yoga:~$ dpkg -l | grep chrom
ii chromium-browser 64.0.3282.167-0ubuntu1 amd64 Chromium web browser, open-source version of Chrome
ii chromium-browser-l10n 64.0.3282.167-0ubuntu1 all chromium-browser language packages
ii chromium-codecs-ffmpeg-extra 64.0.3282.167-0ubuntu1 amd64 Extra ffmpeg codecs for the Chromium Browser
ii libchromaprint1:amd64 1.4.3-1 amd64 audio fingerprint library

Revision history for this message
Olivier Tilloy (osomon) wrote :

Thanks for the report Till. As this sort of issue hasn't been reported by anyone else yet, it sounds like it might be something very specific to your setup (it hopefully is).
Please try and narrow down what might be causing that terrible memory leak.
I'm marking the bug incomplete until you add more information. Thanks!

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Thanks for the quick answer. As a first step I will remove the add-ons, one at each blow-up to find whether it is one of them. First candidate was Ulmon CityMaps2Go.

I assume that there is no hardware defect (broken RAM or so) in the new laptop as Chromium is the only app affected and Chromium does not crash, it simply occupies all the memory after some time. This laptop is my first with 16 GB RAM, I have taken this high amount of memory to be able to run virtual machines. Before I ran 3 VMs with 2 GB each and left 2 GB for the real iron, now I run the VNs with 4GB each and leave 4 GB for the real iron. But this I only do if I actually need VMs, most of the time all the 16 GB are for the real iron and the system starts to swap when Chromium has taken around 13 GB.

Do you have any hints what I could also test to find out what is happening?

Revision history for this message
Sziráki Tamás (sziraki.tamas) wrote :

Seems to me being some similar memory leak here, too. Using Chromium fro few hours, it eats up a huge memory. Since I have got 12 GB this is the first time Ubuntu started to use swap.

Revision history for this message
Olivier Tilloy (osomon) wrote :

You can use the Shift+Esc keyboard shortcut to invoke the chromium task manager, which allows inspecting the memory used by each tab and extension.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

For now the Chromium task manager shows that the memory occupation of the tabs is not growing but only the memory occupation of the main browser process is growing. Also the main browser process uses by average 15 % CPU even if not using the browser.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

When comparing the memory occupation numbers in the Chromium task manager with the output of the "top" command, all numbers in "top" are larger than in the task manager, especially the main task takes several times the task-manager-reported memory in "top".

The CPU consumption of the main task is going up with the time. It is between 30 % and 50 % now. The CPU consumption of the tab and add-on tasks is negligible.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I have removed also AdBlock Plus some days ago (the last remaining add-on) and this seems to have solved the problem. Now it seems that Chromium is not blowing up any more.

But I still like to get able to return to ad-reduced browsing again.

Revision history for this message
dino99 (9d9) wrote :


i also had a similar issue with adblock; now i use uBlock with satisfaction.

Revision history for this message
Tyler Maxwell (tyler-maxwell) wrote :

I have this problem as well. I'm running Chromium on Ubuntu 16.04 and the "browser" process increases memory usage over time, regardless of activity or other tabs memory usage.

It is not as grave as 13GB in 4 hours, but I'm running only a couple of tabs with no extensions and still see the browser processes bloating memory. Generally, after 24h of execution it takes over 1GB of memory and keeps increasing, even if killing all the tabs and extensions.

My current session has only two tabs active, each with around ~100MB and no extensions. This is used for work, so there is no facebook or youtube browsing, no flash.

Revision history for this message
shiva_23 (bombaygull-23) wrote :

i don't think it is an ubuntu specific problem - i have it not only with bionic - same on debian testing too.
also - with script- and ad-blockers - webpages are "ram-eaters"!

Revision history for this message
Zoltán Süle (zoltan-sule) wrote :

Are you sure it is related to the Chrome browser? I experienced this memory leaking thing when I turned on Gnome 3 Taskbar extension.

jefferson (silva21mb)
Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Olivier Tilloy (osomon) wrote :

The original problem reported by Till went away after removing the adblock plus extension (see comment #7).

If others experience similar memory leaks, please file a new bug. Thanks!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.