ubuntu system testing tool ignores system proxy settings, and try to submit report via direct connection

Bug #345548 reported by iav
14
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
Low
Marc Tardif
checkbox (Ubuntu)
Fix Released
Low
Marc Tardif

Bug Description

"Ubuntu System Testing" tool tryes to submit report directly, ignores system-wide proxy settings.

Revision history for this message
Michael Rooney (mrooney) wrote :

Hi iav, thank you for taking the time to report this bug and helping to make Ubuntu better! This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in checkbox.

Revision history for this message
David Murphy (schwuk) wrote :

iav, please can you run checkbox with the following parameters and attach the resulting "checkbox.log" file to this report? Thanks.

`/usr/bin/checkbox-gtk --log-level=debug --log=checkbox.log`

Revision history for this message
iav (iav) wrote :

command run produces following output to console:

root@ubuntu:~# checkbox-gtk --log-level=debug --log=checkbox.log
/usr/lib/python2.6/dist-packages/checkbox/lib/safe.py:20: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/var/lib/python-support/python2.6/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: Warning: invalid (NULL) pointer instance
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: GtkWarning: gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: GtkWarning: gdk_pango_context_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: PangoWarning: pango_context_set_font_description: assertion `context != NULL' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: PangoWarning: pango_context_set_base_dir: assertion `context != NULL' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: PangoWarning: pango_context_set_language: assertion `context != NULL' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: GtkWarning: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed
  "checkbox-gtk.glade"))
/usr/lib/python2.6/dist-packages/checkbox_gtk/gtk_interface.py:59: GtkWarning: gdk_keymap_get_for_display: assertion `GDK_IS_DISPLAY (display)' failed
  "checkbox-gtk.glade"))
/usr/bin/checkbox-gtk: line 6: 6380 Segmentation fault (core dumped) python $CHECKBOX_SHARE/run "$@" $CHECKBOX_SHARE/configs/$(basename $0).ini

Revision history for this message
David Murphy (schwuk) wrote :

I'm not sure you're running the latest version of Checkbox (you can check with `dpkg -l | grep checkbox` - it should be 0.7) as the md5 warning in your log was addressed in 0.7. If it's not, can you upgrade and retest?

Also can you check the value of http_proxy (`echo $http_proxy`) - if you're using the Network Proxy application in the System > Preferences menu, then that should be being set. If you've not used that application, how are you setting the system-wide proxy?

If http_proxy is set correctly, then Checkbox should be using it.

Revision history for this message
iav (iav) wrote :

I am not sure I can upgrade checkbox - I use live usb image downloaded 2 days ago.
I see for $http_proxy, and it was set in "ubuntu" user profile, when I check it in terminal session. But I run checkbox from gnome menu, and I don't know, was it run from "ubuntu" user, or from root. when I made "sudo su -", and check for http_proxy, I found, this var lost login and password.

I can download new image and perform check for checkbox version at monday, if it can be intersting for you.

Oh, I forget to add: when I write this topic starter message, I have checkbox trys to connect; and I look into "netstat -anp", and see checkbox try to connect to the world ip address, not to my proxy ip. And then I wrote about proxy settings "ignorance", not about password errors or something.

Revision history for this message
iav (iav) wrote :

Now I update image, and check again, on another computer.
Now I see, that version of checkbox 0.7, and no updates proposed by synaptic or update manager.

About the proxy: now I see checkbox runs from the root account; and I can confirm:
if proxy wants login and password, and it set via Network Proxy application in the System > Preferences menu, root have proxy and port, but have no login and password.

now I run checkbox in network without the proxy server, but with direct internet connection, and set proxy.

I waits for no one application can connect to internet, because of proxy server is not available;

but checkbox ignores proxy settings and siccessfully send report.

David Murphy (schwuk)
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Low
milestone: none → 0.8-alpha3
status: New → Triaged
Marc Tardif (cr3)
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Low
status: New → Fix Committed
Changed in checkbox:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.8~alpha4

---------------
checkbox (0.8~alpha4) karmic; urgency=low

  * New upstream version:
    * Changed icon.
    * Added timeout property to lock_prompt plugin.
    * Added concept of attachments to tests.
    * Added support for backslahes in templates to wrap lines.
    * Added support blacklisting and whitelisting both tests and suites.
    * Introduced the concept of jobs for suites, tests and attachments.
    * Removed upstart event which is no longer needed.
    * Replaced architecture and category with requires in test definitions.
  * Fixed pygst dependency (LP: #334442)
  * Fixed configuration file updates during install (LP: #330596)
  * Fixed and expanded translations (LP: #347038)
  * Fixed ignored system proxy settings (LP: #345548)
  * Fixed parsing blank lines in templates (LP: #393907)
  * Fixed escaping of lists (LP: #394001)
  * Fixed timeout in manual tests (LP: #377986)
  * Fixed CLI interface dialog.
  * Fixed support for FreeDesktop XDG base directory specification (LP: #363549)
  * Added general and package specific apport hooks

  [ Gabor Keleman ]
  * Fixed untranslated strings in tests (LP: #374666)
  * Fixed untranslated last screen (LP: #374646)

 -- Marc Tardif <email address hidden> Wed, 19 Aug 2009 15:36:05 -0500

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
Marc Tardif (cr3)
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.