bzr index AssertionError: Somehow we ended up with too much compressed data

Bug #1397725 reported by Neal McBurnett
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr (Ubuntu)

Bug Description

It seems that to run bzr search, I need to create a search index. So in my repo I ran

 bzr index .

It ran for a while, saying stuff like Indexing...:Indexing texts: commits 2/4.B
But then it gave me a traceback, as attached. The bottom line was:

  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 144, in finish
    % (self.bytes_out_len, self.chunk_size))
AssertionError: Somehow we ended up with too much compressed data, 4032 > 3976

It happens every time I run bzr index . in this repository, but indexing works in a different repo.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bzr 2.5.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-41.70~precise1-generic
Uname: Linux 3.13.0-41-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.8
Architecture: amd64
Date: Sun Nov 30 11:27:52 2014
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: bzr
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Neal McBurnett (nealmcb) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.