bzr log doesn't resolve symlinks

Bug #1042883 reported by Micah Gersten
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr (Ubuntu)

Bug Description

in lp:qa-regression-testing we have a symlink from scripts/data to data. I tried to run bzr log on scripts/data/well-formed-gray16.tiff and got:
bzr: ERROR: Path unknown at end or start of revision range: scripts/data/well-formed-gray16.tiff

'bzr log data/well-formed-gray16.tiff' worked as expected

I would expect symlinks stored in the repository to files stored in the current repository should be followed, but not symlinks outside of the VCS control or to places outside the VCS directory.

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: bzr 2.5.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Tue Aug 28 13:08:25 2012
EcryptfsInUse: YesInstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
 PATH=(custom, no user)
 SHELL=/bin/bashSourcePackage: bzr
UpgradeStatus: Upgraded to precise on 2012-01-29 (211 days ago)

Revision history for this message
Micah Gersten (micahg) wrote :
Micah Gersten (micahg)
description: updated
Changed in bzr (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.