Does not Depends: ${shlibs:Depends}

Bug #68033 reported by Michal Pokrywka
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Fix Released

Bug Description

acpi-support version 0.90
I run dapper, but I wanted to check new edgy kernel to see if my notebook issues were fixed.
I installed linux-image-generic and acpi-support from edgy repository. It turned out that "multimedia" keys do not work because:
$ tail /var/log/acpid

[Tue Oct 24 19:37:26 2006] received event "hotkey ATKD 00000032 00000005"
[Tue Oct 24 19:37:26 2006] notifying client 4192[108:108]
[Tue Oct 24 19:37:26 2006] executing action "/etc/acpi/ "
[Tue Oct 24 19:37:26 2006] BEGIN HANDLER MESSAGES
acpi_fakekey: /lib/tls/i686/cmov/ version `GLIBC_2.4' not found (required by acpi_fakekey)
[Tue Oct 24 19:37:27 2006] END HANDLER MESSAGES
[Tue Oct 24 19:37:27 2006] action exited with status 1
[Tue Oct 24 19:37:27 2006] completed event "hotkey ATKD 00000032 00000005"

After manual installation of edgy libc6 problem was solved, but it was not what I expect from debian based system.

description: updated
Revision history for this message
Paul Sladen (sladen) wrote :

'acpi-support' didn't used to contain any binary utilities, so ${shlibs:Depends} was probably never included.

Changed in acpi-support:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Revision history for this message
Paul Sladen (sladen) wrote :
Matthew Garrett (mjg59)
Changed in acpi-support:
status: Confirmed → Fix Committed
Revision history for this message
Daniel Hahler (blueyed) wrote :

This is fixed already in Hardy (acpi-support 0.105). It has been fixed in 0.97 probably for Gutsy already ("Depend on the appropriate shlibdeps").

Changed in acpi-support:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.