Comment 1 for bug 187047

Revision history for this message
James Henstridge (jamesh) wrote :

Overall, the patch looks okay to me. A few comments:

 * I wonder if Comparable.__and__() and __or__() doing boolean and/or will be confusing?
 * Would BitwiseAnd and BitwiseOr be better names? That seems to be the names for the operators used here:
    http://docs.python.org/ref/bitwise.html
 * Would it be worth rounding out the remaining bitwise operators? While and/or seem fairly consistently implemented, the others don't so might require per-backend compilation (e.g. xor is "^" in mysql and "#" in postgresql).