Login woes with modify_account_key acls when using candid

Bug #1919160 reported by Sergio Schvezov
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store Server

Bug Description

I tried to login using candid, the only acl set was "modify_account_key", this is done by Snapcraft on "snapcraft register-key".

The web browser pops up accordingly, on the first try after selecting Ubuntu One Staging which had <email address hidden> logged in already and got:

Sentry ID: a85ef35277c64b8287c57a8cde41080d

On the second try, after selecting Ubuntu One Staging I got redirected to the "setup page" with a request to enter my user name (which I had already done a week prior). After taking care of this the login had timed out (note to Snapcraft: need to check if this timeout can be increased in bakery). This second try would have already have worked if not for the timeout.

On the third try, it just worked after selecting Ubuntu One Staging and accepting.

The two things at awe here are:

- user name being reset

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.