undefined symbol: crypto_pwhash_argon2id_opslimit_moderate

Bug #1794703 reported by Alan Pope 🍺🐧🐱 🦄
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Status tracked in Trunk
Fix Committed
Kyle Fazzari
Fix Released
Kyle Fazzari

Bug Description

Snapcraft 2012 worked fine. 2022 failed here, and someone on irc said 2014 broke too. So likely somewhere between 2012 and 2014 things went wrong.

$ snapcraft clean
Traceback (most recent call last):
  File "/snap/snapcraft/2022/bin/snapcraft", line 23, in <module>
    from snapcraft import project, yaml_utils
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/snapcraft/__init__.py", line 387, in <module>
    from snapcraft._store import ( # noqa
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/snapcraft/_store.py", line 36, in <module>
    from snapcraft import storeapi, yaml_utils
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/snapcraft/storeapi/__init__.py", line 19, in <module>
    import pymacaroons
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/__init__.py", line 8, in <module>
    from .macaroon import Macaroon
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/macaroon.py", line 13, in <module>
    from pymacaroons.caveat_delegates import (
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/caveat_delegates/__init__.py", line 4, in <module>
    from .encrypted_first_party import (
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/caveat_delegates/encrypted_first_party.py", line 5, in <module>
    from pymacaroons.field_encryptors import SecretBoxEncryptor
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/field_encryptors/__init__.py", line 2, in <module>
    from .secret_box_encryptor import SecretBoxEncryptor
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/pymacaroons/field_encryptors/secret_box_encryptor.py", line 3, in <module>
    import nacl.bindings
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/nacl/bindings/__init__.py", line 17, in <module>
    from nacl.bindings.crypto_aead import (
  File "/snap/snapcraft/2022/lib/python3.5/site-packages/nacl/bindings/crypto_aead.py", line 18, in <module>
    from nacl._sodium import ffi, lib
ImportError: /snap/snapcraft/2022/lib/python3.5/site-packages/nacl/_sodium.abi3.so: undefined symbol: crypto_pwhash_argon2id_opslimit_moderate

Revision history for this message
Kyle Fazzari (kyrofa) wrote :

I'm bisecting this. Note that 2014 is ppc, the last amd64 rev that worked is 2018.

Changed in snapcraft:
assignee: nobody → Kyle Fazzari (kyrofa)
milestone: none → 2.44
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Kyle Fazzari (kyrofa) wrote :

It seems to be a clash between pymacaroons-pynacl and pymacaroons. In fact, pymacaroons-pynacl breaks if pymacaroons is removed. These actually seem to be the same, with pymacaroons-pynacl being older (and broken), and pymacaroons actually working.

The fix, after several builds, seems to be simply removing pymacaroons-pynacl and only using pymacaroons.

The fix for master: https://github.com/snapcore/snapcraft/pull/2302

The fix for legacy: https://github.com/snapcore/snapcraft/pull/2303

Changed in snapcraft:
status: Confirmed → Fix Committed
Revision history for this message
Robie Basak (racb) wrote :

snapcraft (edge) 2.43.1+git52.gff233cd is working for me. Thanks!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.