Shows "Error while adding the file monitor."

Bug #1043118 reported by Alexander Lazarević
This bug affects 5 people
Affects Status Importance Assigned to Milestone
shutter (Debian)
shutter (Ubuntu)

Bug Description

On startup and after every screenshot I do a dialog pops up with the message

"Error while adding the file monitor.
 Unsupported operation"

The output (which may not be related) on the console is:

INFO: new upload-plugin information detected - /usr/share/shutter/resources/system/upload_plugins/upload/Dropbox
Can't locate Net/Dropbox/ in @INC (@INC contains: /usr/share/shutter/resources/modules /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/shutter/resources/system/upload_plugins/upload/ line 73.
BEGIN failed--compilation aborted at /usr/share/shutter/resources/system/upload_plugins/upload/ line 73.

ERROR: upload-plugin exists but does not work properly - /usr/share/shutter/resources/system/upload_plugins/upload/Dropbox
Use of uninitialized value in numeric le (<=) at /usr/bin/shutter line 9020.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: shutter 0.88.1-1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic-pae 3.2.24
Uname: Linux 3.2.0-29-generic-pae i686
NonfreeKernelModules: openafs nvidia
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
Date: Wed Aug 29 09:02:20 2012
PackageArchitecture: all
SourcePackage: shutter
UpgradeStatus: Upgraded to precise on 2012-04-23 (127 days ago)

Revision history for this message
Alexander Lazarević (e11bits) wrote :
Revision history for this message
Mario Kemper (Romario) (mario-kemper) wrote :

To fix the error please install libnet-dropbox-api-perl. The file-monitor problem: Are you trying to save to a network folder or to a local harddrive?

Revision history for this message
Alexander Lazarević (e11bits) wrote :

My home directory is a network folder (afs)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shutter (Ubuntu):
status: New → Confirmed
Revision history for this message
Aaron Roydhouse (aaron-roydhouse) wrote :

I am long-time user of Shutter. I use it on a laptop with 12.04 and Shutter 0.89.1 with a local home directory. I am not using a network folder. I test changing the Shutter snapshot folder to /tmp just in case.

Recently I started seeing the "Error while adding the file monitor." error while starting Shutter (once for each session image) or when taking a snapshot.

When I start Shutter from the command line this is what I get:
WARNING: Net::DBus::GLib is missing --> Ubuntu One support will be disabled!

WARNING: Gtk2::AppIndicator is missing --> there will be no icon showing up in the status bar when running Unity!

(shutter:2037): gnome-vfs-modules-WARNING **: Could not initialize inotify

Now command line message is displayed when you take a snapshot, you get the "Error while adding the file monitor." in a pop-up dialogue. Has some recent change in vfs or inotify has broken Shutter?

Revision history for this message
Aaron Roydhouse (aaron-roydhouse) wrote :

I've done more investigation and it mostly points to the libgnomevfs or inotify.

I have tried upgrading Shutter to latest stable release (0.90~ppa4~precise1) but same problem.

I have tried downgrading the libgnomevfs packages from the current 1:2.24.4-1ubuntu2.1 release back to 1:2.24.4-1ubuntu2, then logging out and logging in, but that didn't help either, so I reverted to latest stable.

I have tried increasing the number of files that can be watched with inotify from the default 65535 to 100000, in case between Dropbox and Shutter it was running out (though I only have 5000 Dropbox files and 12 Shutter files).


But that didn't help either. In fact Dropbox stopped working too, says 'Can't access DropBox folder'. Again this is a local filesystem folder. I assume gnomevfs and/or inotify flaked for Dropbox too.

At that stage a full reboot appears to clear the problem, and Shutter and Dropbox sprang to life again. inotify is a kernel service so I guess it is possible that the kernel, inotify, or gnomevfs has some sort of resource leak, and one of them is the root cause of our Shutter problems. Anyone more knowledgeable on inotify think that is a valid theory?

Shutter and Dropbox are pretty mission-critical for me so this Ubuntu 12.04 LTS regression is obsessing me :)

Revision history for this message
David Biesack (david-biesack-sas) wrote :

Is there a workaround or preference which can disable this? I don't even know what shutter is trying to do or what the file monitor is. I'm just trying to capture a window

shutter --window --active --exit_after_capture --output=screenshot.png

and this dialog gets in the way. I have to dismiss it three times - very annoying.

I'm running XUbuntu. The files are on my network mounted home directory.

(My workaround was to edit /sudo:<email address hidden>:/usr/bin/X11/shutter
and simply comment out all the calls to
as I don't need this feature, whatever it is.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.