No feedback when creating containers

Bug #886188 reported by James Westby
This bug affects 4 people
Affects Status Importance Assigned to Milestone

Bug Description


Getting started with juju I did the following:

  * set up a local env
  * did "juju bootstrap"
  * did a "juju deploy"

at that point it said that the deploy was done successfully, and status showed the
service in status "null". I tried a juju "ssh" and it said it was still waiting to come up.

Watching the debug-log in the other window showed no messages.

I was then confused and tried to start again as I assumed my charm was crashing
and putting it in to a bad state or something.

Ben explained that the master container was still being built, but had to look
at internal log files to confirm it.

At the very least the debug-log should have a message about this.



Tags: local
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Agreed, even understanding the process I've been confused as to where my local provider is in the process, debug-log is a logical place for "creating master container, this may take a while" or even the full output of the command if debugging is enabled.

tags: added: local
Changed in juju:
status: New → Confirmed
importance: Undecided → Medium
Changed in juju:
milestone: none → florence
Changed in juju:
milestone: florence → galapagos
Changed in juju:
milestone: galapagos → honolulu
Changed in juju:
milestone: 0.6 → none
summary: - No feedback when creating master container
+ No feedback when creating containers
Changed in juju:
milestone: none → 0.8
Curtis Hovey (sinzui)
Changed in juju:
status: Confirmed → Triaged
Curtis Hovey (sinzui)
Changed in juju:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.