test_server_rescue: Instance <_id> could not be found.

Bug #2029507 reported by Amit Uniyal
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)

Bug Description

test failed in master as well (locally too).


Body: b'{"itemNotFound": {"code": 404, "message": "Instance b531df61-3356-41d5-94c1-a66e6e9384d2 could not be found."}}'

stack trace:
Captured traceback:
    Traceback (most recent call last):

      File "/opt/stack/tempest/tempest/common/utils/", line 70, in wrapper
    return f(*func_args, **func_kwargs)

      File "/opt/stack/tempest/tempest/api/compute/servers/", line 244, in test_stable_device_rescue_disk_virtio_with_volume_attached
    server, rescue_image_id = self._create_server_and_rescue_image(

      File "/opt/stack/tempest/tempest/api/compute/servers/", line 139, in _create_server_and_rescue_image
    server = self.create_test_server(

      File "/opt/stack/tempest/tempest/api/compute/", line 272, in create_test_server
    body, servers = compute.create_test_server(

      File "/opt/stack/tempest/tempest/common/", line 338, in create_test_server
    with excutils.save_and_reraise_exception():

      File "/usr/local/lib/python3.10/dist-packages/oslo_utils/", line 227, in __exit__

      File "/usr/local/lib/python3.10/dist-packages/oslo_utils/", line 200, in force_reraise
    raise self.value

      File "/opt/stack/tempest/tempest/common/", line 333, in create_test_server

      File "/opt/stack/tempest/tempest/common/", line 148, in wait_for_ssh_or_ping

      File "/opt/stack/tempest/tempest/common/", line 644, in wait_for_ssh
    raise lib_exc.TimeoutException()

    tempest.lib.exceptions.TimeoutException: Request timed out
Details: None

VM did get created as we can see console logs.

Tags: gate-failure
Amit Uniyal (auniyal)
tags: added: gate-failure
Revision history for this message
Elod Illes (elod-illes) wrote :

Hi Amit, as I see test_stable_device_rescue_disk_virtio_with_volume_attached is passing now. Was it fixed meanwhile?

Revision history for this message
Amit Uniyal (auniyal) wrote :

Hi Elod, yeah I checked last 2 days builds fails and this only failed once [1] only, but in that job many test were failing so may be setup issue. Regarding fix Dan, Sean and gmann (may be others too) were/are rigorously working on fixing gate they merged patches too, may be that fixed it.

So We can close it for now. thanks for looking into it.


this test is failing lot though: test_server_actions.ServerActionsTestOtherA.test_rebuild_server_with_volume_attached

Revision history for this message
Amit Uniyal (auniyal) wrote :

I am not sure with which status we close this.

Revision history for this message
Elod Illes (elod-illes) wrote :

Good question, I don't know either. If we don't know which patch fixed it, then Invalid / Incomplete maybe?

(The other test failure you linked has an OOM kill line [1], so probably that test reaches the point where there is not enough free memory on the controller)


To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.